RedM not starting. Stuck on signing in with Epic(platform)

Before you begin, please read the Client FAQ and Common Questions topic.

If you did not find a solution, fill out the following template and remove this top text.

RDR2 version? Latest
Up to date? Yes
Legit or Pirate copy? Legit
Steam/Epic Games/Social Club? Epic
Windows version? 11
Did you try to delete caches.xml and try again? Y
Error screenshot (if any)

System specifications RTX 3070, Ryzen 7, 32gb ram, 2tb ssd
What did you do to get this issue? Nothing, worked fine till a few hours ago
What server did you get this issue on? N/A, issue is loading RedM as seen on screenshot
Latest CitizenFX_log file
CitizenFX_log_2024-05-13T115218.log (12.5 KB)

.dmp files/report IDs N/A

If an issue with starting:
RDR2 folder screenshot

RDR2/x64/dlcpacks screenshot

Filepath to RedM folder E:\Games\RedM
RedM client folder screenshot

Did you try to disable/uninstall your Anti-virus? yes
Did you start Rockstar Games Launcher not as admin? yes

Also add what you already tried so far.
Deleting appdata folder, reinstalling redm by deleting application data. I am not the only one experiencing this issue as I have several friends having the same with Steam platform.

2 Likes