RedM launches into RDO when joining servers

RDR2 version? red dead online
Up to date? yes
Legit or Pirate copy? legit
Steam/Epic Games/Social Club? steam
Windows version? windows 10 pro
Did you try to delete caches.xml and try again? yes
Error screenshot (if any)

System specifications Ryzen 7, 16gb ram, windows 10 pro
What did you do to get this issue? installed redm for the first time, first server, immediate problem
What server did you get this issue on? western dreams RP and all servers
Latest CitizenFX_log file N/A
.dmp files/report IDs N/A

If an issue with starting:
RDR2 folder screenshot
RDR2/x64/dlcpacks screenshot
Filepath to RedM folder
RedM client folder screenshot
Did you try to disable/uninstall your Anti-virus?
Did you start Rockstar Games Launcher not as admin?

Also add what you already tried so far.

I’ve tried reinstalling RedM about 5 times, reinstalled RDO twice.
tried changing my install version to the newest (experimental) and beta
moving the RedM file to the same Directory as RDO
running the game with Steam and RDO not running
running RDO first then RedM

not sure why but whenever I try to join any RedM server it takes me to the RDO launch screen. its still recognized as RedM because I can access f8.
I’ve see people say the issue is mods or a .meta folder. but they don’t exist as I have modded my RDO

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the Cfx.re community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!
:mascot:

Technically RedM always will launch RDO while loading you to the servers. Were you sitting in the loading screen, or you had the same problem of the game throwing you out to the main menu?

If you could also make a quick video that would help, with F8 on.

not sure what you mean in your question, but I don’t touch anything other then connect server and it puts me into the rockstar rdo instead of the redm server. and unfortunately I have no way to screen record