RedM Graphics settings not saving / Reshade (FIX)

RedM Graphics settings not saving / Reshade install
Found a fix for those who has the issue where RedM wont save graphics settings after restarting the game.

  • While ingame on the server, change all the settings to whatever you like and apply.

  • Now exit the game NOT using ALT+F4 or the menu but by using F8 and typing ‘‘quit’’ Hit enter.

Game will now start with the correct settings.

(Sometimes it can take 2 attempts. Also if you change the API (Vulcan/DX12) and restart. You will have to redo the other settings ^^)

If the fix above isnt working check the system.xml file:

(Hit Win+R Then type %appdata% and hit enter to open AppData)

In there go to the folder listed above.
Rightclick the file ‘‘system.xml’’ and select ‘‘Properties’’.
At the bottom make sure that ‘‘Read Only’’ is NOT selected.

Now for some Reshade. I wont show how to setup everything within as there is plenty of videos on Youtube showing how.

The only thing I will help with is getting Reshade to actualy hook to RedM and work as intended in game :slight_smile:


First off. Download the latest version of Reshade available from their home site.
Current version is 5.2.1 (Planing on using RTGI from Pascal download the 5.2.1_Addon instead)
As you are installing it will tell you to select your game. This is where if you install to RDR2.exe it wont work.
Instead install to this location: (Installdir)-RedM\\data\cache\subprocess
And select the file: RedM_b1436_GTAProcess.exe. (b1436 is my current version as writing this. check top corner while in game for the version you are on)

And thats it :slight_smile: Reshade will now work!

(Also if you do not know how to install Reshade i suggest you watch a video on it as there is a few things you need to setup)

A good graphics mod to go with Reshade is the mod: Visual Redemption!
The mod is from the same developer Razed that made NVR and NVE for GTA5.

VisualR Works with RedM and can be found in their discord :slight_smile:

Doesn’t work

Im currently using reshade and my graphics settings is saving with this fix. Might be something else in your case. Make sure the RedM version of the settings file is not set to read only

‘‘Read Only’’ is NOT selected.
when i Mark off, automatically the folder
reschedule the option