RedM Coming up with error -x100000123 (unable to connect to rockstar game services at this time)

RDR2 version?
standalone
Up to date?
yes
Legit or Pirate copy?
legit
Steam/Epic Games/Social Club?
steam
Windows version?
10
Did you try to delete caches.xml and try again?
no
Error screenshot (if any)

System specifications
What did you do to get this issue?
I have no idea
What server did you get this issue on?
my own local server

This error is REALLY weird because I was under the impression that RedM is completely disconnected from rockstar services. I’ve tried changing gamebuilds, but I really don’t know what else to do. Anybody have a fix?

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the Cfx.re community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!
:mascot: