RedM - Assertion Error on launch (Detailed post)

Hey, RedM has been working perfectly for the past few weeks. However, this morning my client has had an update and now I can’t launch it.

RDR2 version? 1232.62
Up to date? Yes
Legit or Pirate copy? Legit (Rockstar launcher)
Steam/Epic Games/Social Club? Steam / Social club open at the time
Windows version? Windows 10 Pro - Version 1909
Did you try to delete caches.xml and try again? Tried deleting cache and reinstalling FiveM
Error screenshot (if any)

System specifications
AMD Ryzen 5 1600
16GB DDR4 RAM 3200mhz
GTX 1080
1TB SSD <- OS
2TB NVME <- Red Dead install
2TB HDD <- Junk

What did you do to get this issue?
Launch RedM. appears within 5 seconds

What server did you get this issue on? N/A
Latest CitizenFX_log file

[         0] [    DumpServer]                 1260/ DumpServer is active and waiting.
[         0] [          RedM]             MainThrd/ --- BEGIN LOGGING AT Wed Jul  8 13:36:32 2020 ---
[        31] [          RedM]                19244/ Detected NVIDIA Node, attempting to query ShadowPlay status...
[       203] [          RedM]             MainThrd/ CitizenFX Steam child starting - command line: "C:\Users\James\AppData\Local\RedM\RedM.exe" 
[       218] [          RedM]             MainThrd/ hello from "C:\Users\James\AppData\Local\RedM\RedM.exe" 
[       281] [          RedM]             MainThrd/ Got ros:steam process - pid 10004
[       468] [   ROSLauncher]             MainThrd/ hello from "C:\Users\James\AppData\Local\RedM\RedM.app\cache\subprocess\RedM_ROSLauncher" ros:steam --parent_pid=7844 "C:\program files\rockstar games\launcher\launcher.exe"
[       609] [          RedM]             MainThrd/ GlobalError: Assertion failure: m_matches.size() == expected (C:\gl\builds\sVsA2krF\0\cfx\fivem\code\client\shared\Hooking.Patterns.h:125)
[       843] [    DumpServer]                15664/ Process crash captured. Crash dialog content:
[       843] [    DumpServer]                15664/ RedM has encountered an error
[       859] [    DumpServer]                15664/ Assertion failure: m_matches.size() == expected (C:\gl\builds\sVsA2krF\0\cfx\fivem\code\client\shared\Hooking.Patterns.h:125)

.dmp files/report IDs
ac253d90-93e1-4bdf-89e1-8cc8679df3bf.dmp (834.1 KB)

If an issue with starting:
RDR2 folder screenshot

RDR2/x64/dlcpacks screenshot

Filepath to RedM folder
C:\Users\James\AppData\Local\RedM

RedM client folder screenshot

Did you try to disable/uninstall your Anti-virus?
Yes

Did you start Rockstar Games Launcher not as admin?
Yes

Also add what you already tried so far.
Uninstalling RedM.
Clearing Cache
Searching various support forums

I’ve seen people post this issue before but there has been no answer.

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the Cfx.re community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!
:mascot: