Provide not working with exports

Client: Production
Server: “version” is “FXServer-master SERVER v1.0.0.3539 win32”

Expected:
provide in fxmanifest should override exports.

Result:

Category: Server / Client

Reproduce: [test].zip (1.5 KB)

1 Like

brah so sad to see the date of this
well to say it out loud its still not fixed

i have to add support for a scriptA that is dependent on scriptB
then made scriptC and set provide in fxmanifest to scriptB
then when i run it all exports created in scriptC is not defined as scriptB
resulting in scriptA saying that there is no export for scriptB defined!!!

1 Like

I would also like seeing this work.

Buddy of mine has made a fuel resource and to replace LegacyFuel it would be 1000x easier if provide would also work for exports.
Many resources nowadays use exports unlike years ago where seemingly everyone only knew about events.

Welp. This unfortunately hasn’t been fixed as of yet :slight_smile:

This works, it’s used across FiveM.

QBox Core makes use of it.

No, it does not.

It would also be problematic if a resource exports a function with the same name but completely different signature for something it provides for.