Problem with Dunkos VRP editing vrphomes and lscustoms configs

I’ve got 2 config issues I could use some help with, I don’t know for sure if this is the place to ask but I thought I’d try.
I’m trying to add hacker station and drug lab to mansion2 (mountainside mansion) Every thing else is working in the house, can someone help me figure out why the lab and hacker station won’t show up? I’ve tried a lot of different things. I’ve confirmed that the lab and hacker station are functioning in other houses in the server. Also if you tried to plug this into your server it may not work as far as the coords because it’s on a server using a modded franklin house.

My second issue is I’ve tried adding the engine, turbo, and bulletproof tires back into lscustoms, as when I got the pack through zaphosting they weren’t included and something has caused the mod not to load in. I’ll post the config I have for homes.lua and first the not working lscustoms lua and then the unmodified working one for comparison
homes.lua (28.7 KB)
lscustoms.lua (134.1 KB)
beforechangeslscustoms.lua (133.9 KB)