Our players need to delete cache every time they want to join our server


For some unknown reason, every time our players leave the server and want to play again, they have to clear the Five M cache, if they don’t do it, the connection stays in “fetching info”. We have a community of hundreds of players and we are their main server for almost all of them, and its a very annoying problem. Any idea of what is happening?

Best wishes

Have you tried deleting your server cache?

Happy birthday man!. Yeh, absolutely, we always delete cache every time we shut down the server for an update or when it has been too many hours working.

Try not doing that.

Also, assuming this is a real issue and not something happening only for some, can you share your server address/name/join link?

OK, I’m assuming it’s this one?


I just joined this server and then disconnected, restarted the game and joined again and I’m very much not getting stuck anywhere… so there has to be some other issue somewhere.

Yeh, is this.

So you has been there without any problem?. Almost all of our users need to delete cache to get in, so it’s beeing a big issue, we should be already with around 80 players at this hour.

What could be? We have no idea xD.

Thanks for your help btw

Correct, I joined (from the server list, if that matters), loaded in, spawned, and then quit the game.

After that, I joined again without any problem. :confused:

When a client is stuck, can you have them close their game and upload the newest .log file in the FiveM.app/logs/ directory?

I don’t need a lot of them, just one should be enough.

CitizenFX_log_2020-06-04T132752.log (431.9 KB)

Here you go! thanks!!

This seems to be one from June 4th which didn’t even hang or get stuck.

Yeah it started to happen like 3 days ago, and I am afraid we don’t have a backup :S

Do you have a newer log file at least from a case where someone does get stuck?

CitizenFX_log_2020-06-11T124556.log (43.9 KB)

This one it’s from today, sorry for the other one m8.

For this one, has the user clicked to join your server at all? I don’t see a log line saying that. :frowning:

CitizenFX_log_2020-06-11T151933.log (48.5 KB)

This guy is sharing the screen with me and yeah he clicks and stays in fetching till 3 attempts.


OK, nothing looks too unusual there. :confused:

I’m wondering if ‘deleting cache’ helps due to some protection policy on the dedicated server provider, as in - it redownloads resources, keeping a connection open for longer, and otherwise, the game trying to connect is seen as a DDoS attack and blocked, perhaps?

This sounds really painful to investigate without directly being able to check on both affected sides though. :confused:

My mate fixed the problem somehow and it’s everyone inside, he literally said “it’s too long to explain”, but I’l lleave an answer here as soon as possible in case everyone got the same problem.

Appreciate so much your help and attention!!

Best wishes.

Neat! I’m looking forward to find out what you’ve done to solve it, I’ve seen a lot of people asking about ‘fetching info’ sometimes.

Hey, got a chance to post what solved it for you yet? :slight_smile:

Hey!, Still waiting to the foudner to tell me waht the fuck was going on there xD!