Onesync server development

Need help and guide for setting up onesync for my server with 250+ members. Without onesync it’s successfully but I want to expand slots instead of running 2 server. If somebody is willing to guide or help me to setup voice and phones and other stuff to work properly me and the staff would be thankful!

OneSync only supports up to 64 slots. Plus there is a forum post on how to use OneSync.

Voice is already implemented and phones are just resources like every other resource.

I got almost everything working except esx_voice, when we first joined the server players will have “global” voice hearing everyone across the map but if we press shift + H it became normal and working and we cant talk in gpchone. We currently got 2 32 servers running and its full 24/7 because its not whitelisted. What I want is getting 64 working and maybe have one 32 so its 64 + 32.

Pretty sure that is just an issue with OneSync voice where you have a brief global until its set. As far as ESX resources go I can’t help as I don’t use ESX resources and can just suggest you ask the people who made the resource OR ask in the #server-development:essentialmode category.

1 Like

Is there any other choice to get everything working without esx? Im willing to learn it if voice and phones calling works

I mean that is up to you. I build my own resources so I am gonna say its possible but not sure if you are going to actually do all that work or not. Thats up to you. I am not sure of phone resources without ESX / vRP so my guess is to just search the forums.

1 Like

could you help me setting up webrtc with linux? I got linux server and tried but it doesnt work

What are you trying to setup WebRTC for.


I have never installed GCPhone as I work on my own stuff but pretty sure that tells you how to install it.

yeah i installed webrtc but it says
0: Config file found: /root/…/etc/turnserver.conf
0: Listener address to use:
0: Config file found: /root/…/etc/turnserver.conf
0: Domain name:
0: Default realm:
CONFIG ERROR: Empty cli-password, and so telnet cli interface is disabled! Please set a non empty cli-password!
0: WARNING: cannot find certificate file: turn_server_cert.pem (1)
0: WARNING: cannot start TLS and DTLS listeners because certificate file is not set properly
0: WARNING: cannot find private key file: turn_server_pkey.pem (1)
0: WARNING: cannot start TLS and DTLS listeners because private key file is not set properly
0: Relay address to use:

Have you tried asking the people who made GCPhone.

and when i tried to call with webrtc one and send cadidate 12 W3siY2FuZGlkYXRlIjoiY2FuZGlkYXRlOjIxMzgzOTM0OTMgMSB1ZHAgMjExMzkzNzE1MSAxOTIuMTY4LjAuNCA2MzY1NiB0eXAgaG9zdCBnZW5lcmF0aW9uIDAgdWZyYWcgMCtxOSBuZXR3b3JrLWNvc3QgOTk5Iiwic2RwTWlkIjoiMCIsInNkcE1MaW5lSW5kZXgiOjB9XQ==
TO 3 came up but no voice

they only posted this and nothing more

they have an issues tab on github.

It’s working for me na… พี่ใช้ Linux ใช่ไหม ลองรันคำสั่งตาม ลิ้งค์นี้ดูพี่ เสียงโคตรชัด

I got it working long time ago BTW thank you