Nothing shows up when I launch RedM

RDR2 version? Latest version (not sure specifically)
Up to date? Yes
Legit or Pirate copy? Legit
Steam/Epic Games/Social Club? Rockstar Launcher
Windows version? 10 Pro
Did you try to delete caches.xml and try again? Yes
Error screenshot (if any)
Not really errors but screenshots of my problem.



System specifications
i5-9600k
GTX 1660Ti Asus
16GB Ram
What did you do to get this issue?
I have no idea, I just installed it and get this whenever I launch it.

If an issue with starting:
Did you try to disable/uninstall your Anti-virus? Already disabled when I first launched it
Did you start Rockstar Games Launcher not as admin? Yes

Also add what you already tried so far.
I basically deleted everything I could from the RedM File and installed it again, and I also restarted my PC and still get it.

Basically, since installing RedM, I get nothing showing up when I launch, no news, no community posts, no servers, nothing. It acts as if I have no internet connection when I do.

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the Cfx.re community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!
:mascot: