No shop inventory found -- default enabled

Hello I’m having this error while I’m buying items from the shops I get the item but this error appears always is there any fix for that please

Thanks !

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the Cfx.re community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!
:mascot:

I could be wrong, but I believe this occurs if you do not have qb-truckerjob. This is more of an informational output that an error. What version of qb-shops do you have (you should be able to see this in the fxmanifest).

I have qb-truckerjob and also, my qb-shops version is ‘1.2.1’

Interesting… this was removed a couple weeks ago (commit). Is this causing issues? or is it just printing it out? Try pull the latest version from GitHub and see if that makes a difference. If you have the preinstalled version when you created your server it could be an intermediate version that is not up to date.

I downloaded it and used it, but now while I try to buys items it doesn’t bring the menu and it doesn’t show me what to buy and also there is this new error

 script:qb-shops] SCRIPT ERROR: @qb-shops/server/main.lua:166: No such export CreateShop in resource qb-inventory

Thanks

You will need to update your qb-inventory. Note that the inventory had a rather significant overhall, if you do not like how the inventory looks / functions you may wish to use the previous qb-inventory, but you will also need to use the previous qb-shops.

I am using previous qb-inventory, and previous qb-shops for my qbcore but I don’t know what is the issue

You cant be using the previous qb shops as the line that the error refers to doesn’t exist. The function only exists in the newest version of qb shops.

here is my qb-inventory version

and here is my qb-shops version

So unfortunately the version numbers were not updated so they are not a good reference to the exact version you need. The links I posted above refer to a specific version of 1.2.1 for the shops (older), versus your version which is the newer version of 1.2.1 I am assuming.

I trid this previous qb-shops now it was the same : ( but my qbcore build is 8040 does it have to do anything with that ?

No, build should not matter. What is the error that it is giving now? It should no longer have the original error as that function call no longer exists.

I fixed it by updating qb-inventory and qb-shops to the latest version.

By any chance do you think it would be the same if I have ps-inventory? Or would I actually need to add something about “create shop” somewhere into ps-inventory? TIA

I have ps-inventory as well… Did you find a fix to this? @Jonnny420

I confirm I have this issue with ps-inventory
We should wait an Update of ps-inventory right ?

This is really frustrating