My FiveM keeps crashing when I spawn a vehicle

Hello, I am having an issue with adding vehicles to my fivem server. I download them from 5mods and create a stream folder with .yft and .ytd files and I put the .meta files and the __resource.lua in the vehicle folder, basically I do everything right. Then I go to the server.cfg folder and I start the resource and everything seems right. But when I try to spawn it typing car in F8 or using the spawn tool that comes with txAdmin menu, fivem crashes. My friends have tried too and the same keeps happening. This only happens with motorbikes. I only have two that work out of the twenty that I’ve tried. I don’t think this is very hard to solve but I really can’t figure it out. Below there’s an image of the error.
0000error1

The error in the console is ESX calling the CreateVehicle native function. It’s not the problem though.

This issue has happened to me in the past, LONG ago. I forgot how I fixed it.
I feel like some vehicles were bugged so I just avoided them, but others could be fixed.
I just don’t recall how.

Please show the file structure of an addon vehicle you are having issues with, along with the contents of the fxmanifest.lua or __resource.lua file. Just to make sure the resource manifest is filled out correctly and all the files are where they should be. The way you describe it, I am pretty sure you have the files in the right places. But better safe than sorry.

Hello, sorry for wasting your time but I think I just figured it out. So basically my __resource.lua wasn’t complete and there were a lot of files in the car folder that weren’t in the __resource.lua. Anyways thank you for helping me. :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.