Intensive frame loss on Live, Developer, and Blank Servers

Environment questions

GTA V version: Latest: Just reinstalled GTA:V (1.0.2245.0)
Up to date: Yes
Legit or Pirate copy: Legit
Purchased where - Steam/Rockstar Launcher/Epic: Steam
Windows version: 10
Did you try to delete caches.xml (not cache/!) and try again? Yes
System specifications: 2070RTX, 32GB RAM, i9-9900k
CitizenFX crash zip file (‘Save information’ on a crash): N/A (Not crashing)
logs/CitizenFX_log files: (No crash to report)
.dmp files/report IDs: (No crash for .dmp files/report IDs)

If you can’t start the game at all

GTA V folder screenshot: Game starts, N/A
GTA V/update/x64/dlcpacks screenshot: Game starts, N/A
Filepath to FiveM folder: Game starts, N/A
FiveM client folder screenshot: Game starts, N/A
Which antivirus/firewall software are you using? Game starts, N/A
Did you try to disable/uninstall your Anti-virus? Game starts, N/A

Important parts

What is the issue you’re having?
Massive frame drops in the Los Santos area, as well as occasionally in the Paleto Area.
Normally gameplay will be smooth 60-70fps, however until the resolution steps below are followed, the frame drop intensifies to 1 frame every 4-5 seconds. Rendering the game unplayable.

What are you trying to do? Traverse the map.

What have you tried already to fix the issue?
Deleted caches.xml,
Cleared Client Cache,
Cleared Server Cache,
Restart Client,
Restart Server,
Uninstall/Reinstall FiveM
Uninstall/Reinstall GTA:V
Removed all resources from Dev server to ensure it wasn’t a resource that was added into the server. (Barebones artifact server only)
Deleted Dev server, and attempted with latest recommended artifact. (Github page)
Deleted Dev server again, and attempted with newest artifact. (Github page)

–Temporary resolution found, this is the message we have provided to our playerbase to fix the issue.
To fix the frame drop/frame stutter fix after the latest FiveM update:
The best practice is to clear your cache before following the below steps
1) Start FiveM, go to the gear icon (settings) in the top right, scroll down and select Canary , acknowledge the pop-up box, then hit F8 and type: quit
2) Start FiveM, go to the gear icon (settings) in the top right, scroll down and select Release , acknowledge the pop-up box, then hit F8 and type: quit .
3) Start game, then hit F8 and type: quit
4) Restart PC
5) Start game
6) Connect to the server! Issue resolved! \o/

Error screenshot (if any):

What did you do to get this issue?
Joined the server and attempted to move in the city.

What server did you get this issue on?
Both my developer and live server. (AspireRP), and several pinned servers on the FiveM front page. (Using server browser).

Additional comments

I have not introduced anything new to either of my servers since before this problem began after the last few FiveM updates. (as of approximately 4-5 days ago). More info below about the timeframe.

I have now continued my dev work since we have discovered the resolution to the problem. However it is a multistep process that is only achievable by swapping to canary build and back to release, followed by restarting the users PC.

  1. This issue is affecting select users. (~30% of users)
  2. No changes have been made server-side to account for this issue.
  3. I have reverted my dev server down to base server artifact alone, with no scripts running other than what is required, and the issue persists.
  4. The resolution we’ve found comes from toggling to canary, restarting the client, back to release, restarting the client, and then restarting the users PC, to be able to play without issue.

4 of my communities 130 active people have had to reinstall FiveM itself and perform these troubleshooting procedures above to be able to play without their client dropping to 1 frame every 5-10 seconds.
This issue started happening on Canary build 4-5 days ago following a client update, and started affecting the release build yesterday morning following a client update.

The steps provided above have been a 100% resolution to the issue. This leads me to believe this is not a server issue, and leads me to believe the issue is with the game client itself.

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!

If this would be the case, why, then, would it be fixed when re-updating to the exact same release, even after a ‘reinstall’? (i.e. seems more like an edge case issue with some users’ systems?)

Also, you’ve not provided reproduction steps nor an ETW trace file (.etl) of anyone having your alleged ‘issue with the game client’, so I’m not sure what you’re trying to accomplish by posting this…? If it’s ‘raising awareness’, that isn’t part of any path toward getting an issue fixed, as ‘awareness’ isn’t actionable.

We didn’t change anything that could lead to ‘30% of some user cohort getting lots of hitches’ either, so it’s not like just from the info you’ve provided anything could be done… and if it ‘started in a canary build’ why did you not report it with actionable info then so it wouldn’t have ended up in production?

Do you (or affected people) by chance have NVIDIA Broadcast App installed on your system(s)?

A few do, most do not. I was toggling mine on/off during testing to see if it was the cause of the issue. It didn’t make a difference.

This is my first attempt outside of the discord to report the issue. I’m not sure how to replicate it, other than to literally start the game and attempt to join a server. I know that it is not only an issue in my community, it is spread across several communities (AspireRP, Redstaff Republic, Beyond Limits, New Chance, NoPixel, and several others). I’ve reached out and touched bases with other server developers and those in other communities who are pulling their hair out trying to diagnose/troubleshoot this issue.

On the note of the ETW trace file, if literally anyone anywhere would have said “You should include this with your forum post”, it would have been done. I’ll run one the next time the above troubleshooting steps wear off and either I or someone in my community experiences the issue again.

As for reproduction. I don’t have a way to repro it other than to say “play the game on any server and see if you’re affected”, I’d be happy to start up my OBS and record the issue for you to visually see the issue, and how somehow a reinstall to the exact same release will fix the issue.

I’m not here to shit on your work, nor to shit on you. I’m here to bring a problem to light, and it’s beginning to appear more steadily in the cfx discord by more and more people.

This is my first message to bring something to your attention, whether its an issue with my end or with the game client itself. I don’t ask for much, I hardly say much. I mind my own. But I feel warm and welcome already. If this is your response to me first bringing a potential issue to light, and providing what we’ve found to be the fix (maybe something on your end might make sense with what’s given). Then I’ll sit on it and spin. I’ll wait until it becomes more of a widespread issue that actually warrants your attention

Also note that with the latest updates, there is no more caches.xml.
(Not sure the support template needs that question anymore.)

My reply might have been this harsh because it’s the manyth report of the same issue with yet again no info provided at all.

Note that, yet again, I don’t run a server, none of the core team does - and the game works fine for a very large amount of individuals still. This means that edge case issues that only occur on some different setups than we run can only be resolved with the right info, or access to a system the issue occurs on to perform any investigation.

Again, “bringing an issue to light” is not anywhere in the steps to “making anything fixable” and will only make it less likely anyone will feel like fixing whatever issue you are experiencing.

I’m also amazed that the fact traces exist is not known at all, given that I’ve asked everyone I’ve seen report this specific concern before to provide one… yet nobody did so far.

The band-aid I use has worn off. As promised, I have recorded a good 60+ second ETW trace file for you. Please contact me directly via DM or Discord (CrypticError#0001), and I’ll be happy to send it your way. (Preferably here in the forums, and I’ll send the trace file your way.)

Odd - the file shows that ped spawning is somehow sometimes taking 2-3 seconds just to evaluate potential coordinates.

Hopefully this is something easy to resolve. :confused:

Right, found the cause - some code that’s being skipped due to a recent patch apparently at times may forget to re-load the current iterator from memory to a CPU register, which means that in some cases this function will iterate for much longer than it should.

This is a non-obvious bug and would only be hit if in an area with a larger amount of players, so it likely didn’t get hit during testing, since as above we don’t have any server with a lot of players in the same area, nor access to any such server.


Current canary should resolve this issue, however since it’s weekend soon and there’s other big changes in this release that need some more testing I don’t think it’s a good idea to push to production right away, affected users can be told to switch and switch back early next week.


Excellent, I’ll pass the word along to my community, as well as others that are currently being affected. Thank you!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.