Im getting Rage error err gfx init see photo

I have updated the drivers just prior to posting this and rebooted and still i get this same error … any advise on how to get rid of this so i can launch cfx screen. cuz i cant connect if i cant get to the connection cfx screen. thanks.
rageerrr
driverupdate

1 Like

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the Cfx.re community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!
:mascot:

im in the same boat, i’ve done everything known, now my main game doesnt work also.

also following. same thing for me

I’m also having this problem. Some solutions that my server discord came up with are changing the graphics API from Vulkan to DX12. It sounds scarier than it is, just in the advanced graphic settings in the main game settings. Others have gone into their AppData hidden folder to delete the RDR3 settings folder, and that worked for them. I’m not having any such luck.

where is that app data folder at?

You need to go to your C: drive and make sure in view to show hidden folders. The path then should be Users/[username]/appdata/roaming/CitizenFX

Hi everyone, been having the same issue- tried everything everyone else listed as well for a similar GFX error, but this fix from Freumont in the Wild discord worked for me:

Search for %appdata% in your Windows Search Bar then navigate inside the CitizenFX folder. Inside the rdr3_settings folder, edit the “system” XML document with notepad (or Notepad ++).

Under
Replace kSettingAPI_Vulkan with kSettingAPI_DX12
And underneath that, change locked value=“true” to locked value=“false”

(Make sure to leave the brackets in, the forum won’t let me post the brackets!)
Save.

Cfx should now boot.
(It should be noted I tried this this with drivers 471.11, 472.12, 511.79, 517.48- so rolling back your drivers might not be necessary at all.)
I have 3070 Ti

Hope this helps some of you!

You are a life saver. Thank you. After 2 days of trouble shooting, this worked for me. :cowboy_hat_face:

I’m getting this same exact error code and absolutely nothing will fix it. I’ve changed the .xml file, deleted settings folders, deleted sga and vulkan files, any and every fix I could find online I’ve done and nothing is working. RDO runs fine by itself, RedM constantly gives me this error code. If anyone has any advice or solutions please help

2 Likes

unreal. that worked.

Same here with a AMD Graphics card. Driver on the newest version. I already had it when I enabled the New UI on RedM. After disabling the new UI the error was gone. With the new update I can’t disable the new UI so the bug stays there.

Did anyone got a solution?

I an getting this same Rage error: ERR_GFX-INIT
RDR2 works fine for me day in day out no issues
But when launching RedM I get this above error

So im fairly Certain the issue is with RedM

  • I have reinstalled both the game and RedM
  • I have updated my Windows and my Nvidia GPU to newest drivers
  • I have even done what is suggested here and changed to DirectX API as seen below
    image

Yet still can not launch RedM

i copyed my system file from my documents red dead folder to my citizenfx rdr3 settings and it fixed it