I keep getting this error?

I am continually getting this error on my live console, anyone able to help me?

[script:qb-smallresou] SCRIPT ERROR: @qb-smallresources/server/entities.lua:6: attempt to index a nil value (global ‘Config’)
[script:qb-smallresou] > handler (@qb-smallresources/server/entities.lua:6)

Here is the qb-smallresources/server/entities.lua

Restart the resource and check for the Config file erroring

1 Like

well, I feel dumb for sure, I was looking at everything else didn’t even think to let it tell me the issue. I really appreciate you!

Hello guys, I tried to restart the resource but it only gives me the same error

qb-smallresources/server/entities.lua:6: attempt to index a nil value (field ‘BlacklistedVehs’)

What did you do to solve this stupid spammer error?

Thanks in advance

You’ve messed with blacklisted vehicles in the config and broken it. Make sure you have everything in config formatted correctly, not missing any commas, etc

Thanks for replying, but the thing is

I didn’t touch the config file from smallresources, something is missing and I can’t figure out :confused:

This line of code directs to the “config.lua” file in the script.

Open “config/lua” and search for “Config.BlacklistedVehs”, this line should look like this…

Config.BlacklistedVehs = {}

(If you have some blacklisted vehicles still on this list, there is possibly a missing comma somewhere. I personally removed all the blacklisted vehicles, so the line of code should appear as above)