[HELP] esx_doorlock add new doors


If I add a new door for locking it don’t works. The code I set for the door don’t trigger the door for open en close it

Here the code I use:

	-- unicorn 
		objName = 'prop_strip_door_01',
		objCoords  = Vector3(96.09197, -1284.854, 29.43878),
		textCoords = Vector3(96.09197, -1284.854, 29.43878),
		authorizedJobs = { 'unicorn' },
		locked = true,
		distance = 14,
		size = 2

Do I something wrong or is this correct… If this is wrong howto close Doors for Unicorn Club and Michael house (with both a gate)


1 Like

Is this code uncommented?

How do u mean u commented??
Sorry :innocent:

Did you remove the --[[ and ]]

Uhmm :innocent::innocent: no
Damn I feel supid omg… Thanks… Gonna try this

1 Like

thanks alot, u have me back on the road again… but… still no go… The door isn’t still not working. Everyone can walk into the door and no message that u can close or open the door.

So the sollution is near, but howto?

Do you see any errors in f8 console?

Nope get no error and the rest of the Doors working so also the script is not stopping everything works only the new added door not


Vector3 might need to be with an non capital character so vector3()

I can try this… But the working codes have also the ( ) so Thats why I try that… I have copyed the code from a working one in the script and adit the right name and cordinates… But I give it a try without… Let u know

I have found it…
The coords where wrong, now I have found the right coords and it works…

1 Like

what is the good script for the strip club door please

You can use Codewalker to get the coords of any object.

Vanilla Unicorn front and back doors :

		objName = 'prop_magenta_door',
		objCoords  = {x = 96.092, y = -1284.854, z = 29.438},
		textCoords = {x = 95.392, y = -1284.854, z = 29.738},
		authorizedJobs = { 'unicorn' },
		locked = true,
		distance = 2.5,
		size = 1
		objName = 'prop_strip_door_01',
		objCoords  = {x = 127.955, y = -1298.503, z = 29.419},
		textCoords = {x = 128.500, y = -1298.053, z = 29.719},
		authorizedJobs = { 'unicorn' },
		locked = true,
		distance = 10,
		size = 2
1 Like

Alright Thanks you

have tried this but to no avail? any other suggestions on the same topic?

You need unicorn job, fully working for me…

Unicorn job is installed and running perfectly fine, I just can’t lock the doors

Do u have the old doorlock version or new?

vector3 is the old one (in the code)

I’ve used the vector3 and the {x, y, z}