GlobalError: Could not authenticate server license key. maybe a little bit help?

Hi :sos:, i want to start a fiveM server on my local PC before moving it onto a Server, but i encountered a few problems! each time i try to run the server it shows
“GlobalError: Could not authenticate server license key.”
i have tried way to many methods and keys for this!

Im already a week stuck in this position! can anyone explain?
i tried

sv_licenseKey (of course i placed my key)

and i tried

set sv_licenseKey (of course i placed my key)

and even i wrote this little .bat file:


start.bat (423 Bytes)

(ignore unknown commands like >> logs.txt its just to save the logs to a file so i can see my server’s status)

EDIT:
start.bat contains:

cd/
color 0f
echo off
cls
echo --------------------------------------------------------------- > logs.txt
echo Server has lunched
cd /d C:\FXServer\server-data
echo Server Has Started at: > logs.txt
time /T > logs.txt
date /T > logs.txt
C:\FXServer\run.cmd +exec server.cfg +set sv_licenseKey  A key is located here > logs.txt

Here is my server.cfg file
server.cfg (1.9 KB)
Every part is updated to the latest version and i still receive the same erorr! i even tried to run the server on a diffrent computer and follow the rules written in the documents about the server!

and i still dont understand that problem!
i tried to place the key in " " and i tried without and you cant even imagine what i did and tried!!!
logs.txt file output:
logs.txt (3.0 KB)
and i still dont understand wtf is happening! i have more than 8 keys created on the same ip!!
:sos:

yes i have read every article about the keys and dont tell me to check the https://keymaster.fivem.net/ because i was there!
maybe my keys are the problem?

you are not launching from within your server-data directory, you need to cd to server-data first then execute the server.

oh nevermind i see that you are, but this means it does not see your server config.

correction again. it looks like its not able to contact the service… perhaps there server is having issues and should sort itself out.

Do you know how to fix this? I’ve tried a lot of things but it just won’t click together, any help would be amazing, thank you in advanced and i hope you have a great rest of your day!

Hi my server is having the some issues i have tried 3 server keys and none of them work.

Could not authenticate server license key

Update your server version to one that’s not super outdated and you’ll see a full error.

i downloaded the file that was recomended at the very top of the list last night around 11pm.
i was getting the full message but as i tried different keys the message got smaller so i thought i was in the right track. also i used a ip 4 and just a normal ip on my keys so neither of those two key types worked but there is a limit of 3 keys and ive made all three and none work.

So… there is still an error message? if you are on the latest artifact it should give a more detail message, please supply it here.

The other full message i get the other way i tried the key and its the same for all three keys

Could not authenticate server license key. Your key is not matching the initial IP address sufficiently (#2, IP requested is ..., H(in) is GEN13-ARIN, H(ad) is HYLTO6-ARIN6-ARIN). Please create a new key, or run the server on the right provider.

1 Like

Also i was testing this to see if this worked on my personal computer so i could move to a VPS and run it there but i hit the back button while creating a key and then when i clicked the forward button it created my 3rd and last key(which are all on my personal ip) is there anyway to delete the keys.

probalby because you used the server license key on your loca host first and the first time you are using the license key it will automatically IP lock itsself