General Handshake Failure

My friends are not able to join my server, they get the “General Handshake Failure” message, I have everything set up correctly, the port and all that, what is the issue?

Make sure your ports are open UDP AND TCP .

@Boss It is

@sargecommander Not if they get a general handshake error.

Did you set up a DMZ in your router?

@Boss I just set up a DMZ, it needs to be the IP of your local address, correct?

Hello @sargecommander,
I’ve had the same problem,

Here are a few suggestions.

  1. Retry the connection.
  2. try using an alternative connection; such as direct connect or through the browser.
    Here is a link http://forum.fivereborn.com/topic/801/how-to-automatically-connect-to-any-server-on-start-up-no-direct-connect
  3. Make sure you have correctly created your server including port forwarding.

Regards,
Commissioner (1F01),
Glen (5 7 1 6)

@sargecommander said in General Handshake Failure:

@Boss I just set up a DMZ, it needs to be the IP of your local address, correct?

Correct.

@Boss then I don’t know what the problem is

@sargecommander restart your router. It might just need a reboot.

@Boss Nope, still doesn’t. I do have car mods installed, and Whitelisting, but the folder is inactive, I didn’t add in the city.yml thing

@Boss I also have an ipv6 address (I believe it is my public IP) is this a problem?

@sargecommander What brand is your router? Also if you wouldn’t mind, could you post a screenshot of your port forwarding page. Be sure to check here and see if your server shows there.

@sargecommander said in General Handshake Failure:

@Boss I also have an ipv6 address (I believe it is my public IP) is this a problem?

That might be a problem. To what adress are your friends trying to connect?

@Boss My friends are trying to connect to my local address, that’s what the port forwarding is set up on

@CraftKing7777 I have Netgear, and my server does show, it’s just anybody who tries joining it get the General Handshake Failure msg

@sargecommander please name the IP address your friends are using to connect to you. Assuming you have set up portforwarding correctly they should be using your external IP address (the one you can get here) to connect to your server if they’re not on the same network as you are. It wouldn’t work if they were using an address starting with 192, those are for internal use only (your friends can’t use internal IP addresses or they would be looking within their own network)

@Boss @CraftKing7777 sorry for the late response, I was busy yesterday| @afterburn when setting up the portforwading I had to fill in the lost couple digits of my local IP address. My friends are trying to connect to that one. My public address is an ipv6, and I haven’t found a way that would allow me to portforward with that IP

@sargecommander no you are correct in putting your local address in the port forwarding table, it should be like the last rule I have set up (192.168.0.17 being my internal IP address which you can get by typing ipconfig in your command prompt):

But your friends actually have to type in your external IP to connect to you.

@afterburn so I have the portforwading set up correctly… but my server still shows up and my friends are able to attempt to join it, so what is the problem?

@sargecommander have you added the FiveReborn UDP and TCP rules to your Firewall? (Control panel > Firewall > Advanced Settings > Inbound rules > New rule…)