[FREE][QB] Laundromat / Marked Bills / Money Laundering

What’s This?

My players had loads of issues with the traphouse in QBCore, so I made this for my server. It includes a lot of configuration and the config.lua is commented so you can change & configure it to suit your server.

This script is designed to work with gtaDPS’s Abandoned Laundromat MLO, if you do not use this you will need to change the coordinates in config.lua

Features

  • Leave your dirty money at the laundromat while it gets cleaned
  • Phone notification when it’s completed
  • Make more marked bills take longer
  • Earn more from laundering marked bills when police are around
  • Configure the % each machine gives individually
  • Configure the charge for using the machine

Download / More Info

Screenshots

No support is offered anywhere but this thread, do not join my discord or DM me requesting support. If you cannot read I will not support you.

There will not be an ESX version of this script.

5 Likes

Amazing work keep it up.

1 Like

I downloaded this a few moments ago and upon restarting the server, I get this error and nothing showing up in the Laundromat map.

[    c-scripting-core] Creating script environments for qb-overlord-laundering
[    c-scripting-core] Failed to load script @qb-core/import.lua.
[script:qb-overlord-l] Error loading script config.lua in resource qb-overlord-laundering: citizen:/scripting/lua/scheduler.lua:881: No such export GetSharedObject in resource qb-core
[script:qb-overlord-l] stack traceback:
[script:qb-overlord-l] 	[C]: in function 'error'
[script:qb-overlord-l] 	citizen:/scripting/lua/scheduler.lua:881: in metamethod '__index'
[script:qb-overlord-l] 	@qb-overlord-laundering/config.lua:1: in main chunk
[    c-scripting-core] Failed to load script config.lua.

Under advice from friends, I changed line 1 of config.lua to

local QBCore = exports['qb-core']:GetCoreObject()

Which loads up the 3D text at the Washing Machines, but now I get this error

SCRIPT ERROR: @qb-overlord-laundering/server/main.lua:14: attempt to index a nil value (global 'QBCore')

Edit: Got it fixed. Small thing after the fact, changing server/main.lua’s getPlayerData to getPlayer, and now the script works great. Thanks for creating it in the first place!

2 Likes

i got the same error
SCRIPT ERROR: @qb-overlord-laundering/server/main.lua:14: attempt to index a nil value (global ‘QBCore’)
and I have tried to change this server/main.lua’s getPlayerData to getPlayer
but i still get the same error can you help me?

The only other change I made was adding

local QBCore = exports['qb-core']:GetCoreObject()

to the top of server/main.lua, maybe that’ll work?

now it work but it stuck on occupied

Did you manage to get it working, Ive put local QBCore = exports[‘qb-core’]:GetCoreObject() on line 1 on the config file and the getplayerdata was already changed to getPlayer but still getting the error
[script:qb-overlord-l] SCRIPT ERROR: @qb-overlord-laundering/server/main.lua:14: attempt to index a nil value (global ‘QBCore’)

add

local QBCore = exports[‘qb-core’]:GetCoreObject()

to the top of server/main.lua,

I cannot get this working aha Ive done all what you have but still have the following error.
i can press E to wash and it removes Marked_money from inventory but the 3dtxt staying on washing infinite.

Failed to load script @qb-core/import.lua

try to edit the time in the config like this
CONFIG[‘BaseTime’] = math.random(4,5) – time in minutes the washing machine always takes
–CONFIG[‘BaseTime’] = 1

CONFIG[‘TimePerItem’] = math.random(3,4) – time in minutes each additional item of dirty money adds
–CONFIG[‘TimePerItem’] = 1

unfortunately still the same Failed to load script @qb-core/import.lua gutted lol

Right it can clean marked money if i use 1 machine at a time, if i was using more than 1 machine th rest stay stuck on occupied