[FIX] Assertion Failure

[FIX] Assertion Failure: vkAllocateMemory(Device,&MemoryAllocateinfo, nullptr, &ImageMemory)

crash

The Problem:
For this Crash, My issue occurred while changing the Settings of RedM to fit what I needed, one wrong change of my display crashed the game and refusing to load up again.

Steps I Tried:
From the pain of being unable to open the game to fix the settings, I tried to reinstall RDR2/RDRO First to no avail, changing tactics to deleting everything possible that I could find for RedM and reinstalling the Application more than 3 times.

The Solution:
Well with my dismay My Friend/Acquaintance, Spazzy went through the trouble of finding the solution to the point of exploring all the files and the folder addresses being called by RedM which we found out there was a hidden folder located at "%APPDATA%\CitizenFX\rdr3_settings\"

The Solution is you need to delete the rdr3_settings folder located in the CitizenFX folder, for me it worked instantly allowing me back in RedM to never touch display settings again.


Steps/Images:

Windows Key + R
appdata

%APPDATA%\CitizenFX\rdr3_settings\

Delete the folder then open the game, it’ll recreate the rdr3_settings and should fix the issue

1 Like

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the Cfx.re community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!
:mascot:

:slightly_smiling_face:
I hope this helps anyone facing this issue.

Hey guys. I tried all steps but there is still the crash. I get an Blackscreen and a few seconds after the same error message appears. I begging for help, i cant start RedM and i tried every simple step like delte the folder, reinstall, everything.

I just wanna play man xD

What Error are you getting?