FiveM UI starts lagging because of high GPU usage.

IF YOU DO NOT FILL THIS OUT, YOUR TOPIC WILL BE UNLISTED AND CLOSED

To receive support, please fill out the following template, and remove this top text.


Environment questions

GTA V version: Latest
Up to date: Yes
Legit or Pirate copy: Legit
Purchased where - Steam/Rockstar Launcher/Epic: Steam
Windows version: Windows 10 Pro
Did you try to delete content_index.xml and try again? Yes
System specifications: Nvidia GeForce GTX 770M, Intel Core I7, 16GB Ram
CitizenFX crash zip file (‘Save information’ on a crash): //
logs/CitizenFX_log files: //
.dmp files/report IDs: //

If you can’t start the game at all

GTA V folder screenshot:
GTA V/update/x64/dlcpacks screenshot:
Filepath to FiveM folder:
FiveM client folder screenshot:
Which antivirus/firewall software are you using?
Did you try to disable/uninstall your Anti-virus?

Important parts

What is the issue you’re having? UI lag after playing for a short amount of time in the server.

What are you trying to do? Play without UI lag.

What have you tried already to fix the issue? Deleting my cache, reinstalling FiveM, reinstalling GTA, reinstalling GPU drivers

Error screenshot (if any): //

What did you do to get this issue? Just normally playing. Joined in FiveM and it started happening.

What server did you get this issue on? Be specific and name some, ‘all of them’ by itself isn’t useful! Italian Paradise RP


Additional comments

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the Cfx.re community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!
:mascot:

1 Like

This is a Windows bug MS is refusing to fix, also affects various streaming apps (OBS, Looking Glass). There’s a workaround option in the FiveM settings.

And what is the setting?

It literally says ‘fix UI lag’ or so.

I tried, but my graphics card crashes. What can I do?

Are you using any ‘graphics mods’? Graphics mods are incompatible with this option as they assume the only D3D user is base GTA.

No, I don’t use any graphics mods.

Ah, that’s annoying… weird edge case setups that don’t take well to single-process mode. :confused:

I wonder if there’s any generic app out there already to set D3DKMT priority. :thinking:

What can I do to fix this annoying problem?

What can I do to fix this annoying problem?

If you’re talking about NUI lag, u might try limiting game FPS from your GPU Driver settings Here’s tutorial from Project Homecoming Wiki

It doesn’t let me change the maximum FPS