Failed handshake to server

I keep receiving a failed handshake to server to connect to port 30120:connection refused-CURL code 7. how can I fix this my friends can join but I cant connect


Is there a fix for this so far? My friend is having the exact same issue.


same just now not sure wtf everything was fine.

1 Like

This is happening to me too please help.

1 Like


I am unsure if your issue is fixed, however, these are the possible issues.

– Steam is down, or being serviced in your area.

– The server itself is developing a connection issue for players.

Please paste your .yml file to a pastebin, that most likely will help people to fix your issue.


Here is the .YML for my friends server:

Link Removed – Proportionality

Same issue, he gets a general handshake error, with CURL Code 7. Other players and I can join the server, but he cannot join, even though it is his own.

Disable the following at see if it does anything:

- crashdet
- whitelist

Also, just edited your post as it contained your RCON password.

1 Like

Unfortunately that did not work. Same error issue.

1 Like

Something is blocking the connection, just not sure what.

1 Like

Quick update. I found in a post from back in July/August to attempt doing a direct connect, but with the IP, INSTEAD of his own.

My friend tried this, and was able to successfully join his own server.


Then ports are most likely th problem.

I got it working by using the IP you gave I just changed the 1


I need help with this mine is doing the same thing. im not sure what you guys are saying about changing the port. can someone explain this to me?

Where does 1 find the .yml file?

Failed handshake to server - Failed to connect to port 30120: Bad access - CURL error code 7 (Couldn’t connect to server). what i need to do to fix that

Hey Where Do I find That ?LOL

1 Like

were do u find your yml

Im getting the same problem with my public server, other people can join but I cant, my pc is home hosted and Im getting the handshake error. I tried wireless and lan on my pc and nothing works. do I need to port forward?

1 Like

Necroing posts