Explosion natives no longer working after 1436.31 update

Description: All explosion natives tested are no longer functional after the Jul. 29 client update.
Server artifact version: 5715
Expected behavior: Explosion should be rendered and cause damage
Current behavior: Nothing occurs, standing on exact coords no damage is afflicted either
Error screenshot: N/A
.dmp/crash files: N/A
Files/Code to reproduce bug: N/A
Extra information:

AddExplosion is no longer working with the latest client update. I have tested this native both with my full server/resources and only the cfx defaults running, no luck. This was just working 2 days ago while I was building my heist script, and the only thing that has changed is the client being updated. Server artifacts remain the same. Tested on both DX12 and Vulkan, no change. I also switched client update channel to latest with the same result.

Natives tested:

AddExplosion - 0x7D6F58F69DA92530
AddExplosionWithUserVfx - 0x53BA259F3A67A99E
AddOwnedExplosion - 0xD84A917A64D4D016
0xB7DF150605EEDC9B (add explosion on entity)

All natives were tested by invoking their hash directly.

Through help from @t3chman setting the game build to 1311 restores these functionalities, so it’s present only on 1436.

Thanks for the report. Apparently R* has added some tunable checks when those natives are called/synced via SCRIPT_COMMAND_EVENT. We obviously don’t need these checks and don’t operate with tunables at all. So I just disabled this logic:

Full list of checked natives:

0x7D6F58F69DA92530; // FIRE::ADD_EXPLOSION
0x34AE85C7CA4857AA; // FIRE::0x34AE85C7CA4857AA

UPD: test on canary now :tada:

1 Like

Happy birthday :slight_smile: @Disquse

All my explosions suddenly stopped working in redM. I simply use addExplosion() in LUA scripts. Is there a fix for this? I’ve noticed streamers all over the place on multiple servers being very confused during bank robberies because the dynamite never goes off, but the vaults still open.

I don’t really understand the comment by Disquse. What is the easiest way to fix this for LUA scripts in redM?

Ty this is confirmed working again on my end (latest client channel)

It is on the latest client channel for testing before it is rolled out globally. Also, it has nothing to do with Lua specifically it was the game engine having additional checks with the latest 1436.31 update.

I guess I’m not sure how to update the redM client with the testing stuff from Github. Wait… I get it, you mean the update channel in setting inside RedM.

… YES! That fixed it. Thank you!