Different fivem identifiers = admin problems

Hi all

I am hosting an qb-core server at home, and till now it have been great.
We played yesterday with no problems, but when I started the server up today, I suddently lost my admin priveliges in-game.

After long research, I found out that my “fivem” identifier have changed

In admins.json it is one number, and if I see my player profile in txadmin it’s another number.

If I add my “new” number from txadmin into server.cfg in the line add_principal identifier.fivem:XXXXXXX group.admin #PLAYERNAME
I get some admin rights, like spawning items, reviweing, etc. but I still do not have access to txadmin in-game as before. (I get an error message, saying that my identifiers do not match)

I have tried to delete admins.json and the default folder in txData, and run the whole setup from start, but I still have to different fivem identifiers.
In admins.json there is a line url that contains my “old” or wrong fivem identifier (“nameid”:“https://forum.cfx.re/internal/user/XXXXXXX”) so I have a feeling, that something is coming back wrong from cfx.re ?

What is happening here?

Go in TxAdmin and go to the admin manager on the left, add your player as an admin and it should save all the identifiers and allow /tx and hot keys in game.

“my” player is already added there and is my master account.
And it’s still giving me wrong fivem identifier from something recieved from cfx.re

I solved this problem, by deleting my crx.re ID under my master account.
When that is added, it adds an identifier in admins.json, that are called fivem and instead of your fivem ID it’s your cfx.re ID.
It’s a issue that most likely started at last update, as I had my cfx.re ID added on my master account since I created the server - With no issue.

I solved this problem by opening and logging on my discord on my computer, hope this helps