Could not load resource metadata file __resource.lua

Hello,

I have recently started a FiveM server again, I started to add some custom resources, none of them load and they just fail to find metadata file

Im running ubuntu 16.04

Here’s my server starting log:

https://ghostbin.com/paste/5rjqt

I have fx-server in
/home/sam/fivem/fx-server

I have the cfx-server-data file in
/home/sam/fivem/cfx-server-data

My server.cfg is in my cfx-server-data file, which is also where I start the server with this start.sh

cd /home/sam/fivem/cfx-server-data
bash /home/sam/fivem/fx-server/run.sh +exec server.cfg

My server.cfg

ndpoint_add_tcp "0.0.0.0:30120"
endpoint_add_udp "0.0.0.0:30120"

start mapmanager
start chat
start spawnmanager
start fivem
start hardcap
start ■■■■■■■
start els-fivem
start pmenu-title
start chat
start vvoice
start brakelights

sv_scriptHookAllowed 1

rcon_password <redacted>

sv_hostname "OriginGaming.Net"

#exec server_internal.cfg

#load_server_icon myLogo.png

set temp_convar "hey world!"

#sv_master1 ""

#sv_authMaxVariance 1
#sv_authMinTrust 5

add_ace group.admin command allow # allow all commands
add_ace group.admin command.quit deny # but don't allow quit
add_principal identifier.steam:110000112345678 group.admin # add the admin to the group

sv_endpointprivacy true

sv_licensekey <redacted>

If anyone has any idea why this might be happening please let me know, thanks!

Nevermind, fixed it, my file permissions were a bit fucked up, just had to run it with sudo

how u fixed it :slight_smile:

1 Like

Don’t remember, this post is 2 years old, don’t bump super old posts. It has something to do with handling.meta

In my case, the issue was the file was encoded in an unsupported format (UTF-8 with BOM). Hope it may help someone.

There’s nothing wrong with bumping an old post with a valid reason since these posts pop up when people search stuff on Google.