Controls fucked up

So my problem is, that every time I restart RedM my control settings are fucked up. But the thing it they’re not getting resetted to default controls. → “Error screenshot”
I tried deleting the settings.xml (and Folder) from RDR2 folder in “Documents” and also settings.xml (and Folder) from Appdata > Roaming > CitizenFX > rdr3_settings.
I also tried changing the settings in the normal game (not RedM)

RDR2 version?: 1.0.1436.31
Up to date?: Yes
Legit or Pirate copy?: Legit
Steam/Epic Games/Social Club?: Epic Games
Windows version?: Windows 11 (Version 21H2) (OS Build 22000.856)
Did you try to delete caches.xml and try again?: Yes
Error screenshot (if any):
System specifications:


What did you do to get this issue?: Just restarted RedM
What server did you get this issue on?: Private server
Latest CitizenFX_log file: md_5 paste
.dmp files/report IDs: N/A

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the Cfx.re community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!
:mascot:

Im having the same issue, i’ve also noticed that’s when you change any settings they don’t save, and revert back to the messed up settings, This happens not just for controls but also for graphic settings. i’ve tried just about everything OP has tried and even reinstalled RDR2 without luck, Im also running the Epic version.

Bump, still having this issue

still having this issue, even after reinstalling RDR

Figured out that there is not “controls” section in C:\Users\My-User-Name\AppData\Roaming\CitizenFX\rdr3_settings\system.xml. Dunno if that has anything to do with my issue, but I just noticed it since it has graphics, advanced graphics and video sections