Chat cannot build

For some reason, chat cannot build on my local server in FxDK. I tried installing dependecies manually with yarn but that didn’t work either. Any ideas?

I have the same problem. It says “Could not find dependency yarn for resource chat.”

If I manually activate the yard resource, then it says it needs webpack which can not be activated. When I try to activate webpack it gives this error message “Running build tasks on resource webpack - it’ll restart once completed.”

Until we find a fix, I type my commands in the console.

I found a fix for that, i replaced yarn, webpack and chat with the same resources from another project and it works fine. Must be a bug with the build that the app creates?

Make sure yarn and webpack from cfx-server-data/resources/[system]/[builders] are enabled, or, if on canary, create new project and it will have them enabled by default.

Same here. I just created a new project and started it, but it doesnt work.


Creating script environments for _cfx_internal
Found new resource baseevents in C:/Users\Usuario\Desktop\faiv\Server\.fxdk\fxserver/resources//baseevents
Found new resource basic-gamemode in C:/Users\Usuario\Desktop\faiv\Server\.fxdk\fxserver/resources//basic-gamemode
Found new resource chat in C:/Users\Usuario\Desktop\faiv\Server\.fxdk\fxserver/resources//chat
Found new resource fivem-map-skater in C:/Users\Usuario\Desktop\faiv\Server\.fxdk\fxserver/resources//fivem-map-skater
Found new resource hardcap in C:/Users\Usuario\Desktop\faiv\Server\.fxdk\fxserver/resources//hardcap
Found new resource mapmanager in C:/Users\Usuario\Desktop\faiv\Server\.fxdk\fxserver/resources//mapmanager
Found new resource playernames in C:/Users\Usuario\Desktop\faiv\Server\.fxdk\fxserver/resources//playernames
Found new resource sdk-game in C:/Users\Usuario\Desktop\faiv\Server\.fxdk\fxserver/resources//sdk-game
Found new resource sessionmanager in C:/Users\Usuario\Desktop\faiv\Server\.fxdk\fxserver/resources//sessionmanager
Found new resource spawnmanager in C:/Users\Usuario\Desktop\faiv\Server\.fxdk\fxserver/resources//spawnmanager
Found new resource webpack in C:/Users\Usuario\Desktop\faiv\Server\.fxdk\fxserver/resources//webpack
Found new resource yarn in C:/Users\Usuario\Desktop\faiv\Server\.fxdk\fxserver/resources//yarn
Found new resource monitor in C:\Users\Usuario\AppData\Local\citizenfx\sdk-storage\server\recommended\citizen/system_resources//monitor
Found new resource webadmin in C:\Users\Usuario\AppData\Local\citizenfx\sdk-storage\server\recommended\citizen/system_resources//webadmin
Creating script environments for sessionmanager
Started resource sessionmanager
Creating script environments for monitor
Started resource monitor
Creating script environments for sdk-game
Started resource sdk-game
Creating script environments for yarn
Started resource yarn
Running build tasks on resource webpack - it'll restart once completed.
Could not start dependency webpack for resource chat.
^3Couldn't start resource chat.^7
Creating script environments for playernames
Started resource playernames
Started resource basic-gamemode
Started resource spawnmanager
Creating script environments for mapmanager
Started resource mapmanager
Creating script environments for hardcap
Started resource hardcap
Creating script environments for baseevents
Started resource baseevents
Started resource fivem-map-skater
Running build tasks on resource webpack - it'll restart once completed.
^3Couldn't start resource webpack.^7

Hello all,

I am experiencing the same issue, however, I am totally new here.
The webpack resource can’t start and I have a hard time to figure why also.

I am using the latest version (March 17, 2021) of Cfx.re Development Kit.
The webpack resource is enabled but appears in gray as it cannot load.

I tried to take the resources from another running server, same issue.
I tried to take the resources from the git (GitHub - citizenfx/cfx-server-data: Data repository for CitizenFX servers.),
with different versions from git, latest from Master, V2.1, etc … same issue.

I am not familiar with webpack, is it possible that we missing a dependency?
I looked into the Dev Kit logs trying to find a more explicit error message, didn’t find any error related to webpack. (AppData\Local\FiveM\FiveM.app\logs)

I will keep looking for this error tomorrow and learn more about webpack.
Any suggestion is welcome.

Read the edits for my not so convenient workaround. Make sure you agree with the pros and cons before doing it.


ORIGINAL POST:

Ok, so on my project created on 14th of March I somehow managed to start the webpack resource (I don’t know how), but the chat resource still won’t start.

I even tried making a new project so that it automatically download the latest server-data. Same story, even worse, as webpack won’t start at all on a new project. I tried replacing the chat resource on the built version, still won’t start.


EDIT:

After some more messing around, I found a fix for the built version of the server. I don’t know how to do it for the Cfx.re DK yet, but if I figure it out I will make another edit. Apparently the order in which the resources are ensured in the resources/resources.cfg is wrong.

The original was:

ensure basic-gamemode
ensure chat
ensure playernames
ensure hardcap
ensure mapmanager
ensure spawnmanager
ensure baseevents
ensure sessionmanager
ensure fivem-map-skater
ensure webpack
ensure yarn

with webpack and yarn at the bottom, and chat somewhere at the top.

After moving webpack and yarn to the top and chat to the bottom, everything works as intended.

ensure webpack
ensure yarn
ensure basic-gamemode
ensure playernames
ensure hardcap
ensure mapmanager
ensure spawnmanager
ensure baseevents
ensure sessionmanager
ensure fivem-map-skater
ensure chat

At the moment, I don’t know if changing the order has any unexpected consequences but all the resources started correctly multiple times.


EDIT 2:

Finally, I managed to get them working on DK. Just download the zip file and replace the resources (make sure everything is stopped; delete the resource folder first, do not overwrite). Then open Cfx.re, disable the chat resource (make sure yarn and webpack are still enabled) and start the server. After everything loaded, enable and start the chat resource and let it do its thing. If all went well, next time you start the server, the chat should start by itself.

[LINK REMOVED]


Pros:

  • It works.

Cons:

  • Every time you build your server, you will have to disable the chat resource and then manually paste it in the built version (as you will get a “too many files” error). You will also have to manually edit resources.cfg (see the first edit for that).

I tested your solution and it works for me as well.
I’m wondering, where is your resources.zip file coming from?

Both resources were generated by the Cfx.re DK on the 14th this month (I don’t know what version they are or how versions work). Then I played around with their starting order, renaming them and stuff and now they somehow work.

Just for information,
I am making it work by replacing Chat and webpack with the resources you provided.
I did a clean replace (remove then add).
I did not need to change the order of executions in my resources.cfg

After investigating some more I discovered that the problem could be the DK. I tried multiple times with both normal version and canary and in separate partitions (C and D) because I wanted to see if anything changes.

Every time I made a new project and never modified or changed the original resources. The results were always the same.

When starting the server from the DK, webpack and chat never built. I even left the server running for 30 minutes once and nothing happened. But if I make a build of the server and run start.cmd both resources get build in a couple of minutes (tested multiple times, always same result).

After that, I can move webpack and chat from the build version to the DK version, along with their cache. This way, they work on DK server, but I can’t build the server again as the chat resource has too many files, so I have to disable it and install it manually after the server is built.

I searched the entire forum again, I see more people having this problem but no responses. No one knows how to fix it.

1 Like