Centos7 mono-complete

anyone know how to get this working server side i have mono installed but get this error
mono CitizenMP.Server.exe
Missing method .ctor in assembly /root/gta5/bin/CitizenMP.Server.exe, type System.Runtime.CompilerServices.ExtensionAttribute
Can’t find custom attr constructor image: /root/gta5/bin/CitizenMP.Server.exe mtoken: 0x0a000001

Unhandled Exception: System.TypeLoadException: Could not load type ‘System.Runtime.CompilerServices.ExtensionAttribute’ from assembly ‘CitizenMP.Server’.
[ERROR] FATAL UNHANDLED EXCEPTION: System.TypeLoadException: Could not load type ‘System.Runtime.CompilerServices.ExtensionAttribute’ from assembly ‘CitizenMP.Server’.



@dazholmes login to ur vpn and type(copy and paste):

wget “http://keyserver.ubuntu.com/pks/lookup?op=get&search=0x3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF” -O out && sudo apt-key add out && rm out

after that type:

echo “deb http://download.mono-project.com/repo/debian wheezy main” | sudo tee /etc/apt/sources.list.d/mono-xamarin.list


sudo apt-get update





After that you should be able to run mono CitizenMP.Server.exe

Hey centos doesn’t use apt i’m not sure what to replace that with on centos… it uses yum

Also why would i need to install a ssh key?

@dazholmes lol im dumb for that. didnt see the centos7 part. but i recommend using ubuntu 14

@iago i’m not using ubuntu just to host a gta server i’m hosting over 10 servers atm with tcadmin so yeh not switching just for this as it’s stupid that it only works on ubuntu i hope they fix that in the future

@dazholmes i only suggested it because i dont really get errors all the time. im sure people have gotten it working. Try this in order obviously:

Obtain necessary gpg keys:
mkdir Mono
cd Mono
wget http://download.mono-project.com/repo/xamarin.gpg
Import gpg key:
sudo rpm --import xamarin.gpg
Add Mono package repository:
sudo yum-config-manager --add-repo http://download.mono-project.com/repo/centos/
sudo rpm -Uvh http://download.fedoraproject.org/pub/epel/7/x86_64/e/epel-release-7-2.noarch.rpm
Update everything:
sudo yum update
Start installing Mono:
sudo yum install mono-devel
sudo yum install mono-complete

yum-config-manager: command not found :frowning:

sudo rpm -Uvh http://download.fedoraproject.org/pub/epel/7/x86_64/e/epel-release-7-2.noarch.rpm
Retrieving http://download.fedoraproject.org/pub/epel/7/x86_64/e/epel-release-7-2.noarch.rpm
curl: (22) The requested URL returned error: 404 Not Found
error: skipping http://download.fedoraproject.org/pub/epel/7/x86_64/e/epel-release-7-2.noarch.rpm - transfer failed

@dazholmes Take a look at this. Maybe it will help. http://stackoverflow.com/questions/11782096/installing-lastest-mono-on-centos-6

centos 6 but still should work the same

@iago thanks anyways could you possibly look at this also

CentOS is a shitty linux distro, Ubuntu is consistent with it’s patches and fixes. This means we support Ubuntu no other Linux distro.

@kanersps I wouldn’t call it shitty i’ve been using it with no problem so far, I guess that’s just your personal opinion, I’ve used ubuntu for years and went over to centos and think centos os better tbh but that’s just me



You have here everything you need to get it working.

yum install yum-utils
rpm --import “http://keyserver.ubuntu.com/pks/lookup?op=get&search=0x3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF
yum-config-manager --add-repo http://download.mono-project.com/repo/centos/
Run a package upgrade to upgrade existing packages to the latest available. Then install Mono as described in the Usage section.

The package mono-devel should be installed to compile code.

The package mono-complete should be installed to install everything - this should cover most cases of “assembly not found” errors.

The package referenceassemblies-pcl should be installed for PCL compilation support - this will resolve most cases of “Framework not installed: .NETPortable” errors during software compilation.

The package ca-certificates-mono should be installed to get SSL certificates for HTTPS connections. Install this package if you run into trouble making HTTPS connections.

The module mono-xsp4 should be installed for running ASP.NET applications.

i fixed it i downloaded https://t.co/VLCEFXgZcU
then did ./configure
make install
everything works now