Can't set myself as admin

I cannot set myself as admin in my server. When I’m in-game, I can’t use start and stop for resources, it says access is denied. That also happens for certain standalone scripts that require admin privileges.
However, I can run ESX-related admin commands, such as setjob and giveitem.

What I’ve tried:

Adding the following in my cfg

add_principal group.admin group.user
add_principal group.superadmin group.user

add_ace resource.extendedmode command.add_ace allow
add_ace resource.extendedmode command.add_principal allow
add_ace resource.extendedmode command.remove_principal allow
add_ace resource.extendedmode command.stop allow

add_principal identifier.steam:xxxxxxx group.admin
add_principal identifier.license:xxxxxxxx group.admin

I tried both resource.extendedmode and resource.essentialmode (I’m running extendedmode though).
I tried with my Steam and License identifiers.
Should these commands be in a specific part of the server.cfg?

Running the above commands manually

I ran the above commands in the txAdmin console too


I tried using setgroup with admin, superadmin, group.admin, group.superadmin

Setting myself the groups in the DB

I manually tried setting my group column of the ESX/EXM DB to admin and superadmin

1 Like


1 Like

I think you are missing.

add_ace group.admin command allow