Attempting to setup RedM for the first time - Epic Games

RDR2 version? Latest
Up to date? Latest
Legit or Pirate copy? Legit
Steam/Epic Games/Social Club? Epic Games
Windows version? 10
Did you try to delete caches.xml and try again? Yes
Error screenshot (if any) See below
What did you do to get this issue? I was trying to set up RedM for the very first time and encountered the below issue both before and after clearing my RedM cache.
What server did you get this issue on? N/A
Latest CitizenFX_log file Won’t let me upload the log file to the forum post.
.dmp files/report IDs

If an issue with starting:
RDR2 folder screenshot N/A
RDR2/x64/dlcpacks screenshot N/A
Filepath to RedM folder %localappdata%\RedM\\cache
RedM client folder screenshot N/A
Did you try to disable/uninstall your Anti-virus? N/A
Did you start Rockstar Games Launcher not as admin? I launched it as admin and non-admin and received the same error both times.

I have tried clearing my RedM Cache several times, uninstalling & reinstalling both RedM and RDR2 several times, and every time I get this error as a result. I downloaded RedM from and have tried just about everything I’ve found on other forum posts, YouTube guides and even the website belonging to the server I’m applying to and am at a bit of a loss on how to get this set up properly. Any assistance would be much appreciated!

Error Description because it will not allow me to upload the image:

An unhandled exception (of type nlohmann::detail::type_error) caused RedM to stop working. A crash report is being uploaded to the RedM developers. Exception details: [json.exception.type_error.302] type must be string, but is null.

EDIT: A friend who uses RedM has been attempting to help me troubleshoot since yesterday to no avail. We have added UpdateChannel=canary and SavedBuildNumber=1355 to my Citizen .ini file, redownloaded RedM another couple of times, and tried running RedM with just the Rockstar Launcher, Rockstar Launcher & Steam, and all 3 applications open and are still getting the same error above at every step. I’m beginning to get a bit discouraged. :frowning: Is it because I use the Epic Games copy of the game? Or is there something else both of us are missing? They said that there’s no reason I shouldn’t be able to get RedM to launch given my current setup.

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!

1 Like

This can be closed. Managed to figure it out on my own. Apparently you can only launch RedM with an EG copy if Rockstar and Steam is closed, which wasn’t immediately apparent according to any video or forum post I was able to come across.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.