XboxOne Controller connection issue

Environment questions

GTA V version: STEAM VERSION
Up to date: YES
Legit or Pirate copy: LEGIT
Purchased where - Steam/Rockstar Launcher/Epic: STEAM
Windows version: WINDOWS 10
Did you try to delete content_index.xml and try again? N/A
System specifications: INTEL 7 10700K - WINDOWS 10 SYSTEM
CitizenFX crash zip file (‘Save information’ on a crash): N/A
logs/CitizenFX_log files: N/A
.dmp files/report IDs: N/A

If you can’t start the game at all

GTA V folder screenshot: N/A
GTA V/update/x64/dlcpacks screenshot: N/A
Filepath to FiveM folder: N/A
FiveM client folder screenshot: N/A
Which antivirus/firewall software are you using? N/A
Did you try to disable/uninstall your Anti-virus? N/A

Important parts

What is the issue you’re having?

  • The current issue I am having is I can no longer use my Xbox One controller when connecting to the GTAV Steam version via the FiveM application, I have connected to other games on Steam and they work fine with my Xbox One controller. I have also noted a lot of people in my community and on the Cfx.re Discord having issues using the controller too.
    What are you trying to do?
  • I have tried updating my controller, I have uninstalled and reinstalled. My controller work when you uncheck ‘Xbox Controller Configurations’ but I want it to work how it always has and was working last time I used it. I have exhausted all options now.
    What have you tried already to fix the issue?

Error screenshot (if any):

  • N/A
    What did you do to get this issue?
  • Tried to play GTA V on FIveM
    What server did you get this issue on? Be specific and name some, ‘all of them’ by itself isn’t useful!
    GTA V in a whitelisted community.

Additional comments

I believe a lot of FiveM users are having issues on FiveM and being able to use their controllers. This doesn’t appear to be a Steam issue as other games work fine and so does GTA V off the FiveM platform.

3 Likes

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the Cfx.re community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!
:mascot:

1 Like

It is still a Steam issue. Since Valve has refused to assign us an ‘app ID’, we’re stuck with using a workaround to enable Steam authentication, and this workaround does not work with Steam Input, and, in fact, breaks, as of the Steam update on November 16/17th.

(to be precise, with Steam Input enabled, any application loading the Steam APIs - which we do for authentication - gets the native Windows input APIs forcibly replaced with Valve’s version of it, but since we don’t have an app ID of our own, it uses the configuration for what appears to be a ‘random’ Steam app with weird/non-functional bindings, this is a bug on Valve’s side, and it not happening with other games for you is somewhat obvious since you’re likely not playing any other games that use this method of enabling Steam authentication)

This is not something we can change since Steam is a closed-source application maintained by Valve, the configuration options/APIs for this Valve exposes depend on being assigned an app ID, and end users can only circumvent it by using other input mapping options and not relying on Steam Input.

2 Likes

Maybe i dont get it right but what is my option for input not using steam ?? Thanks

so we cant do anything about it?

The OP indicated that unchecking “Xbox Controller Configurations” allows the controller to work in FiveM currently.

it does, I had my right stick click in off for my Radio button thats why I am guttered it’s not working

You could try and get ahold of Steam and show support for CFX to get an appID for FiveM, or to support using Grand Theft Auto’s appID when opening FiveM

1 Like

Will there be a fix for this or anything that can be done just wondering? :slight_smile :slight_smile:

I personally am unaware of any possible solution, other than what I’ve described above, having the community push Steam to provide the required system.

1 Like

My controller problem with the ps4 controller is
it works on five m until i leave the screen and come back then it fails
ive tried other games on steam no problem its only on five m
if i reload five m the controller works but stops working if i leave screen and come back

I’m unable to reproduce this, can you tell me where things differ in our reproduction steps and/or supply your own?

Current steps I’m taking:

  1. Plug in Xbox One controller,
  2. Start Steam in Big Picture Mode,
  3. Have Xbox Configuration Support checked (Xbox Extended Feature Support unchecked),
  4. Start FiveM through Big Picture,
  5. Join a server,
  6. Run around with Xbox controller.

All steps are also tested with PS5, Switch, and Steam controllers.

I believe the thing here is that it’s failing with the auto-injected gameoverlayrenderer context (likely as it inherits the Source SDK app ID and its configuration), i.e. not launching from a manual Steam shortcut but just using the Windows shell.

Spot on, that got it reproducing, including it working with Xbox Configuration Support unchecked and not working with it checked.

Yup that’s the issue I am having