vMenu

Source code

Hi, do you know why is taking 1ms?

Hi my vmenu doesn’t work in server. Here is the config file. Idk what is the problem here.

exec permissions.cfg

Only change the IP if you’re using a server with multiple network interfaces, otherwise change the port only.

endpoint_add_tcp “0.0.0.0:30120”

endpoint_add_udp “0.0.0.0:30120”

DB connection string

set mysql_connection_string “server=127.0.0.1;database=essentialmode;userid=root;password=”

set es_enableCustomData 1

add_ace resource.essentialmode command.sets allow

add_ace resource.essentialmode command.add_principal allow

add_ace resource.essentialmode command.add_ace allow

These resources will start by default.

ensure mapmanager

ensure chat

ensure spawnmanager

ensure sessionmanager

ensure fivem

ensure hardcap

ensure ■■■■■■■

#ensure scoreboard

ensure screenshot-basic

Essentialmode

start essentialmode

start es_ui

start mysql-async

start esplugin_mysql

ESX

start async

start es_extended

start esx_menu_default

start esx_menu_list

start esx_menu_dialog

start es_admin2

start vMenu

start instance

start skinchanger

start esx_skin

start esx_accessories

start esx_addonaccount

start esx_addoninventory

start Ambulancejob

start esx_basicneeds

start esx_billing

start esx_boat

start esx_datastore

start esx_dmvschool

start esx_drugs

start esx_identity

start esx_joblisting

start esx_jobs

start esx_license

start t1ger_mechanicjob

start esx_menu_default

start esx_menu_dialog

start esx_menu_list

start esx_migrate

start esx_policejob

start esx_service

start esx_shops

start esx_sit

start esx_society

start esx_status

start esx_vehicleshop

start esx_weaponshop

#Dev

start coordsaver

start JD_logs

start b2k-minimap

#Phone

start esx_addons_gcphone

start gcphone

start xsound

#ESX Mods

start esx_ambulanceGarage

start esx_communityservice

start esx_criminalrecords

start esx_doorlock

start esx_dressingroom

start esx_illegal_drugs

start esx_inventoryhud

start esx_inventoryhud_trunk

start esx_lscustom

start esx_med

start esx_plasticsurgery

start esx_property

start esx_scoreboard

start esx_sit

start esx_tpems

start esx-checkdeathcause

#Probinsyano

ensure LegacyFuel

ensure st-hud

#ensure trew_hud_ui

ensure 3dme1

ensure b1g_props

ensure boatsntows

ensure boostgauge

ensure Calm-AI-V3

ensure car_dealership

ensure CarryPeople

ensure dpclothing

ensure dpemotes

ensure fax-logo

ensure fivem-ipl

ensure harybo_litter

ensure hc-barber

ensure helicamera

ensure Jail-System

ensure jsfour-idcard

ensure loaf_tv

ensure lux_vehcontrol

ensure map

ensure mumble-voip

ensure mythic_notify

ensure np_garage

ensure orp-banking

ensure progressBars

ensure raid_clothes

ensure Reload_Holster

ensure rp-radio

ensure setroannounce

ensure Sil-2Step

ensure Teleport

ensure vehcontrol

ensure vir-deathscreen

ensure vstancer

ensure warmenu

ensure xnTattoos

ensure ym-dispatch

#Robbery

ensure esx_vangelico_robbery

ensure esx_YachtHeist

ensure fivem-drilling

ensure meta_libs

ensure np-truckrobbery

ensure shoprobbery

ensure t1ger_bankrobbery

ensure utk_fingerprint

ensure utk_hackdependency

#Maps

ensure bobo_prison

ensure bobo_prison_lobby

ensure ewmrpd

ensure ls_black_white

ensure newpillbox

ensure Parking

ensure vg_aston

ensure xmas

ensure vgcc

#EUP

ensure assets-clothing

ensure peds

ensure femalepack

ensure maleclothing

#Cars

ensure probieuamerican

ensure probijdm

ensure probioffroad

ensure probipolice

ensure probiemechanic

I haven’t confirmed this myself, but the issue mentioned in this thread seems to be caused by vMenu.

@Vespura

Sorry for the message, I know you are no longer actively developing for this, but is there a chance you can see what is causing the “SCRIPT ERROR in tick: System.InvalidOperationException: Operations that change non-concurrent collections must have exclusive access. A concurrent update was performed on this collection and corrupted its state. The collection’s state is no longer correct” error that some people are seeing at the moment.

I’m on latest artifact, latest version of vMenu getting this error.

Kind regards,

Shane.

Love this menu! It goes great in all servers.

I’ve been getting this randomly as well, haven’t figured out what causes this yet.

1 Like

Hello!!
I have installed vMenu yesterday, set up the permissions aswell, everything seems to be working, except for the noclip!?.
Inside the menu the option for noclip it’s working, but when I press f2 it doesn’t…
The key is set for “289”

Any idea of what could it be?
Thanks.

Is it possible to change the lettering on the top (where it says vMenu by default)?

it aint working i pushed m and it aint even open

Its say me:

Couldn’t load resource vMenu: Couldn’t load resource vMenu from resources:/vMenu/: Could not open resource metadata file resources:/vMenu//__resource.lua.

Can you help me guys ?

if it doesn’t work, you did it wrong. Try again and read the instructions.

Hey,

If you find out, would you be willing to post an update to resolve / mitigate the issue?

Kind regards,

Shane Martin

@Vespura vmenu_smooth_time_transitions This feature has been removed.

“smooth_time_transitions” It’s a pretty cool effect. I really love this.
How do I achieve this effect in the new version?

Hi,

i had the same issue and changed

add_ace builtin.everyone “vMenu.NoClip” allow
to
add_ace group.admin “vMenu.NoClip” allow

and added myself to the admin group of vMenu (permissions.cfg)

restart vMenu and that should do the trick.

actually, it was always working, its weird cause on my keyboard noclip is * but the key is set to f2 lol
so I was clicking f2 and nothing but if i press * i have noclip. i even changed keybindings and is still the same.

So i’m having the issue where only a few of my members are not allowed to spawn more then one vehicle even though that have Replace Previous Vehicle unchecked. When they respawn a new vehicle it will delete their old one. Could be a setting in the vMenu?

My permissions are working fine for admins and moderators but if a normal user spawns weapons, they are being kicked over and over for spawning weps… I set allow all because that is what I wanted but no dice. I don’t want to remove permissions altogether because I want the kick/ban system…

On line 20 try changing it from what you have currently, so if it is true then set it to false or if it is false set it to true

Do you have the auto ban cheaters enabled in your cfg?