getting an issue atm.

[vMenu] [WARNING] An error occurred while checking for the latest version. This is not a problem, vMenu will still work correctly. Please check your version manually.
[vMenu] Error infor: Specified value has invalid HTTP Header characters.
Parameter name: name

Any idea whats going on or how to fix it? We checked and we have the latest version of vmenu, we even went as far as to remove vmenu and reinstall it.

1 Like

i found the issue with the perms. but i was wondering, is there a way a “summon all players” option could be added for admins and owners?

1 Like

Eh, sure, guess it go in misc settings then as there’s not really a suitable place to put this. Post it on the github issue that is pinned, called something like “feature suggestions”.

Ehm, maybe try deleting your uuid file inside the vMenu folder?

could be under player options and set admin as default to view it?

Found the issue, thanks for reporting it. It’s been fixed in the development branch.

Issue was caused because I had implemented some permissions/user config checks in the function that gets the saved weapons before restoring them, when this actually should’ve been implemented in functions that call the get function. Because if I needed to get the saved weapons (no matter if restore weapons is enabled or allowed, whenever I just need it) then it wouldn’t return anything because it did the permission/config option checks.

This was not easy to find because it only happened when you either:

  • have no permissions to access the weapon-restore options in the misc settings, or in the weapon loadouts menu.
  • had the restore weapons options disabled in both the weapon loadouts menu and the misc settings menu.
  • only happened on skin-change, not whenever the player spawned in the server for the first time.

Conditions like those are critical for finding such bug. I appreciate every attempt of ‘reporting a bug’, but please be specific.
Just saying “whenever changing skins, the inventory (later, after another comment which could’ve been prevented if enough info was provided in the first place, identified as weapons) gets cleared” is simply not enough. And it will take me even longer to try and figure out what the actual issue is instead of me putting time into solving the issue.

Please use the following template when reporting issues.

This template will automatically be provided for you whenever creating a bug report on the GitHub issues page.

But it’s not really specific to your current player (player options refers to ‘options to set for your current ped/player’).

Online players doesn’t seem right either since it has a list of players and options specific to certain players only, not one button to trigger them all.

It’ll have to go in misc settings, unless I make a completely separate menu for it, which is unlikely.

It’s apparently (possibly) related to this:

From what I’ve heard it’s a known issue and will hopefully be fixed.


@Vespura found the permission I was looking for - incase anyone else reports weapons disappearing they need to have add_ace builtin.everyone “vMenu.MiscSettings.RestoreWeapons” allow in their permissions :slight_smile: silly me.

That’s a temporary workaround, however it shouldn’t have to be like that. Restore weapons is meant for respawning after being dead, not when switching models. Switching models should always restore the weapons no matter the permissions or user settings. So that’s why it’s a bug, and not a case of ‘you didn’t add the permission in’. :wink:

To compound it, im still getting reports of people logging in and their weapons being gone…lol…its intermittent and doesnt really seem to have a pattern.

Strange, weapons restoring on join is a new feature btw, not fully tested. But since anytime I test stuff it always seems all my testers are unavailable, I couldn’t do proper testing. (not blaming anyone here btw, just never the right time it seems).

oh well, at least the menu is usable and it’s not like you’re “suddenly missing a feature” since it wasn’t implemented before. Also note that restore weapons on join, only works if you’ve selected a default loadout, not when you have Restore Weapons turned on in the misc settings menu. That’s a completely separate feature.

Please provide the full addons.json file, not just a single section.
Also, if you add anything after that last one, I hope you do add the , after the current last one?

ah, turns out you have multiple vehicles with the same exact spawn name, or at least added them multiple times in the list, because I get this error when trying to use your file:

System.ArgumentException: An item with the same key has already been added.

will add a check for that, for now, fix your list and don’t add multiple entries using the same name.

Hey Vespura,

First of all, amazing mod. Really appreciate your work.

But I do have a problem. It’s not a bug tho I guess.

Whenever I connect to a server having vMenu installed it doesn’t load up. I can press F1 and F2 or m as much as I want nothing happens. Everybody is using vMenu like normal.

I seem to be the only one having these issues on different servers.

Additionaly, when I press the BACK button on my controller the menu pops open and closes immediately as long as I press the button.

vMenu Info:

  • Server ip:
  • vMenu Version (check the about menu):
    v2.0 +
  • Do you have access to the files?
  • FXServer artifacts version:

CitizenFX.log of your own demo server (I pressed F1 several times after the message Vmenu outdated)

I’m really desperate about this error and nobody can help.
I tried reinstalling GTA /FiveM several times, launching without additional mods, and clearing caches.

Also I’m using windows 8.1

Is there anyway some can tell me how to change where it says “vMenu” at the top to say something custom?

By default the control is M on keyboard, or holding the back button (change camera) on controller for ~400ms.
Not F1, so yeah it’s completely normal that F1 wouldn’t have worked on my server. However, F2 should have.

Looking at the log shows this error:

[    186188] Error invoking callback for event vMenu:ConfigureClient: System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.TypeInitializationException: The type initializer for 'Newtonsoft.Json.Serialization.DefaultSerializationBinder' threw an exception. ---> System.MethodAccessException: Error verifying Newtonsoft.Json.Serialization.DefaultSerializationBinder:.ctor (): Method System.Runtime.Serialization.SerializationBinder:.ctor () is not accessible at 0x0001

[    186203]   at Newtonsoft.Json.Serialization.DefaultSerializationBinder..cctor () [0x00000] in <07e3893119a945b29a35e81930b1c8ad>:0 

[    186219]    --- End of inner exception stack trace ---

[    186235]   at Newtonsoft.Json.JsonSerializer.Create () [0x00000] in <07e3893119a945b29a35e81930b1c8ad>:0 

[    186250]   at Newtonsoft.Json.JsonSerializer.Create (Newtonsoft.Json.JsonSerializerSettings settings) [0x00000] in <07e3893119a945b29a35e81930b1c8ad>:0 

[    186266]   at Newtonsoft.Json.JsonSerializer.CreateDefault () [0x00011] in <07e3893119a945b29a35e81930b1c8ad>:0 

[    186282]   at Newtonsoft.Json.JsonSerializer.CreateDefault (Newtonsoft.Json.JsonSerializerSettings settings) [0x00000] in <07e3893119a945b29a35e81930b1c8ad>:0 

[    186297]   at Newtonsoft.Json.JsonConvert.SerializeObject (System.Object value, System.Type type, Newtonsoft.Json.JsonSerializerSettings settings) [0x00000] in <07e3893119a945b29a35e81930b1c8ad>:0 

[    186313]   at Newtonsoft.Json.JsonConvert.SerializeObject (System.Object value) [0x00000] in <07e3893119a945b29a35e81930b1c8ad>:0 

[    186328]   at vMenuClient.MainMenu.SetPermissions (System.Object dict) [0x001bf] in C:\projects\vmenu\vMenu\MainMenu.cs:281 

[    186344]   at (wrapper dynamic-method) System.Object:CallSite.Target (System.Runtime.CompilerServices.Closure,System.Runtime.CompilerServices.CallSite,System.Type,object)

[    186360]   at (wrapper dynamic-method) System.Object:CallSite.Target (System.Runtime.CompilerServices.Closure,System.Runtime.CompilerServices.CallSite,System.Type,object)

[    186375]   at vMenuClient.EventManager.ConfigureClient (System.Object addonVehicles, System.Object addonPeds, System.Object addonWeapons, System.Object perms) [0x00000] in C:\projects\vmenu\vMenu\EventManager.cs:71 

[    186391]   at (wrapper managed-to-native) System.Reflection.MonoMethod:InternalInvoke (System.Reflection.MonoMethod,object,object[],System.Exception&)

[    186407]   at System.Reflection.MonoMethod.Invoke (System.Object obj, System.Reflection.BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00032] in <a4e3abdd630b4c98a9d6f31a99197de6>:0 

[    186422]    --- End of inner exception stack trace ---

[    186438]   at System.Reflection.MonoMethod.Invoke (System.Object obj, System.Reflection.BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00048] in <a4e3abdd630b4c98a9d6f31a99197de6>:0 

[    186453]   at System.Reflection.MethodBase.Invoke (System.Object obj, System.Object[] parameters) [0x00000] in <a4e3abdd630b4c98a9d6f31a99197de6>:0 

[    186469]   at System.Delegate.DynamicInvokeImpl (System.Object[] args) [0x000e7] in <a4e3abdd630b4c98a9d6f31a99197de6>:0 

[    186485]   at System.MulticastDelegate.DynamicInvokeImpl (System.Object[] args) [0x00008] in <a4e3abdd630b4c98a9d6f31a99197de6>:0 

[    186500]   at System.Delegate.DynamicInvoke (System.Object[] args) [0x00000] in <a4e3abdd630b4c98a9d6f31a99197de6>:0 

[    186516]   at CitizenFX.Core.EventHandlerEntry+<Invoke>d__5.MoveNext () [0x00064] in C:\gl\builds\edf06b9b\0\cfx\fivem\code\client\clrcore\EventHandlerDictionary.cs:85 

Looks like newtonsoft.json is broken. Try re-installing GTA V, that usually works. Alternatively, I’ve heard someone was able to fix this by downloading vMenu, taking the Newtonsoft.Json.dll from that download, and placing it inside your GTA V installation folder manually, however I’ve never actually had this issue myself, so I can’t really repro this to test it.

1 Like

There’s only like 1 or 2 submenus where it says that, all other (sub)menus have the player’s name, or the submenu title. So there’s literally no reason why you’d want to change this.

You can change the server info tab in the about menu using convars, however removing credits is against the license. Also note: no support for modifying source code.

Yeah noticed after asking, busy day.

Thank you very much, this file had to be replaced.

Kudos to you :mascot:

Hey there, first off: love the mod, making the change from lambda to a scripthook-free server so smooth!

Now its possible I over-read this somewhere in the documentation, if so I’m sorry ^^. Is there any way to disable the spawn of certain vehicles? Like the new War Arena ones for instance, I don’t want to disable the whole class and our blacklist script is slowing down the server quite a bit.