UI has become unresponsive since last update

When using tools inside RedM like Spooner, since the last patch a number of days ago has become completely useless. The UI now hangs and becomes unresponsive for an undetermined amount of time, it’s unclear exactly what the cause is but prior to the last patch it was working perfectly fine and without issue.

What could have cause this issue? We are still investigating how many other resources are impacted by the patch, I’ll report additional findings.

To add, Spooner is a critical tool used to place props, peds, objects, etc… all around the map and have them be visible for clients. This is an important tool for mappers to build things for events. Any chance someone could take a look into why it’s become so unresponsive?

If their is anything I can do to help diagnose the issue please let me know.

1 Like

Provide reproduction steps, the “spooner” resource as well (or a smaller resource where the issue would be easily reproducible). It’s impossible to analyze anything like that. I don’t feel any changes when I’m working with my CEF UI (assuming you meant CEF).

We tried the latest 7220 build. Seems very stable.

It does indeed break at some point of using the NUI. I’ll try creating some resource in order to break it.
I tried to get some info on this but it’s very hard because it’s never happening to me, only some of my players.
It happens in two cases :
→ Good PC specs : after a lot of playtime ( 3-4 hours + ), it becomes laggy and if you still play it like this it wil break at a short time after.
→ Not so good PC specs : Even in the first minutes of playing it will break. I had some players that were taking the beggining test and it was blocking on it, i passed him the test from the database and after looking at his settings he was above the limit, like 4.3GB / 4GB MAX.
It doesn’t error out anything in the console, the game is still runing but it seems like the NUI Focus is getting in the background, even for the F8 console, it’s behind it somehow. [ if you could write in F8 before you can still write but if you couldn’t you can’t click on the bar ]

I don’t know if these infos help very much but i think you may try maxing out the graphics and build some heavy JS thing in order to break the focus.

I think a lot of the existing resources don’t break because most of them don’t use the mouse for the interaction, they only use keyboard input.

I’ll try in my server to make a command to disable the NUI focus and reset it and i’ll check if this solves the issue.

You have no idea how relieved I am to find out I’m not the only one struggling with this issue.

I’d chalk it up to the Spooner resource itself but I’ve also noticed other issues. It seems to have started with the chat box. Chat would be stuck to the screen and it wouldn’t fade-out after like it usually did… Then stuff started happening with the Spooner resource. It was very delayed and got pretty much unusable… then a few days later after trying to diagnosis it, I noticed now that the in-camera would no longer freeze when opening the Spooner resource, f8 menu, or chat. So when I’d usually go to selcect something with my mouse, the in-game camera follows with it.
I’ll post the whole list of things I’ve tried with no success. I rely on RedM for recording a webseries so you can tell Ive been working nonstop trying to fix this.

The menu delays itself so much until it eventually just freezes my input. Issue happened overnight with no clear cause. Started around a month ago(?) I think.

Things I’ve done to try to fix:

  • UI Lag fix on RedM main menu. No difference
  • Switching between release, beta, and unstable builds of RedM
  • Changed sever files out with an older version of the RedM CFX files. Surprisingly did nothing
  • Reinstall RDR2
  • Verifiy files
  • Reinstall RedM
  • Reinstall the Spooner Resource
  • Clear application cache
  • Clear server cache
  • Clear Vulkan Pipeline files
  • Delete user settings for both RDR2 and RedM
  • Was upgrading hardware - new GPU and updated drivers. Issue applies on both a 2070s and a 4090
  • Tried rolling back gpu drivers to a version I know worked good before for RedM
  • Unload resources one at a time to see if one of them was somehow conflicting
  • Tried creating an entirely new server from scratch. Used new installation of all resources (still happened, must not be server-specific?)
  • Tried lowering grahpics settings and only 30% gpu usage, nope
  • Tried unloading maps I had loaded incase it was a draw distance issue overloading the Spooners prop control systems
  • Updated Intel and cpu drivers
  • Windows Update
  • Tried different mouse/keyboards
  • Tried disabling Shadowplay Overlay, no difference
  • Tried both Vulkan and Direct X versions for Graphics API
  • Tried Vsync on or off
  • Moved RedM files to be on same drive as RDR2

^ Posing all that because I’m hoping someone more tech-savvy than me will be able to see something I’m not. Also sorry for the long list lol. Kinda freaking out because I rely on Spooner to record scenes

1 Like

Did you manage to figure out the issue ? I am still stuck on how to fix this too.

We got a newer version of it released by Spooni, it’s running like a dream again.