"this server does not have a license key specified"

Server Artifact Version: 5848
Operating System (Windows/Linux): windows
Error screenshot (if any):

Crash files (if any):
Server config (server.cfg):

Only change the IP if you’re using a server with multiple network interfaces, otherwise change the port only.

endpoint_add_tcp “0.0.0.0:30120”
endpoint_add_udp “0.0.0.0:30120”

These resources will start by default.

ensure mapmanager
ensure chat
ensure spawnmanager
ensure sessionmanager
ensure basic-gamemode
ensure hardcap
ensure rconlog

This allows players to use scripthook-based plugins such as the legacy Lambda Menu.

Set this to 1 to allow scripthook. Do note that this does not guarantee players won’t be able to use external plugins.

sv_scriptHookAllowed 0

Uncomment this and set a password to enable RCON. Make sure to change the password - it should look like rcon_password “YOURPASSWORD”

#rcon_password “”

A comma-separated list of tags for your server.

For example:

- sets tags “drifting, cars, racing”

Or:

- sets tags “roleplay, military, tanks”

sets tags “default”

A valid locale identifier for your server’s primary language.

For example “en-US”, “fr-CA”, “nl-NL”, “de-DE”, “en-GB”, “pt-BR”

sets locale “en-US”

please DO replace root-AQ on the line ABOVE with a real language! :slight_smile:

Set an optional server info and connecting banner image url.

Size doesn’t matter, any banner sized image will be fine.

#sets banner_detail “https://url.to/image.png
#sets banner_connecting “https://url.to/image.png

Set your server’s hostname. This is not usually shown anywhere in listings.

sv_hostname “FXServer, but unconfigured”

Set your server’s Project Name

sets sv_projectName “My FXServer Project”

Set your server’s Project Description

sets sv_projectDesc “Default FXServer requiring configuration”

Nested configs!

#exec server_internal.cfg

Loading a server icon (96x96 PNG file)

#load_server_icon myLogo.png

convars which can be used in scripts

set temp_convar “hey world!”

Remove the # from the below line if you want your server to be listed as ‘private’ in the server browser.

Do not edit it if you do not want your server listed as ‘private’.

Check the following url for more detailed information about this:

Server Commands - Cfx.re Docs

#sv_master1 “”

Add system admins

add_ace group.admin command allow # allow all commands
add_ace group.admin command.quit deny # but don’t allow quit
add_principal identifier.fivem:1 group.admin # add the admin to the group

enable OneSync (required for server-side state awareness)

set onesync on

Server player slot limit (see FiveM - Server hosting for limits)

sv_maxclients 48

Steam Web API key, if you want to use Steam authentication (Sign In)

→ replace “” with the key

set steam_webApiKey “”

License key for your server (https://keymaster.fivem.net)

sv_licenseKey cfxk_1–redacted–

Path to server files: C:\FXserver\server
Path to cfx-server-data files: C:\FXserver\server-data

Describe your issue
Hi! I’m trying to set up a private Red Dead server, following these instructions: Setting up a Vanilla FXServer - Cfx.re Docs

I’ve pretty much got it I think, but it’s not recognizing the server key that I generated at keymaster.fivem.net

I’ve got it pasted in at the bottom of my server.cfg, “svlicenseKey (my key here, starts with cfxk)”

But any time I run the batch file to start the server it errors with “this server does not have a license key specified” Any ideas what I might be doing wrong?

What have you tried?
Sought help on the Discord channel, but that ended up going in circles. The gist seems to be I can’t activate the key without running the server, but I can’t run the server because the key isn’t active. Not sure where to go from here. Any advice would be appreciated!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.