The OneSync EAP and you

Same problem @Mrhack

Hello I have the same worries how the corrected?

Hey, my server get this error:
no candidates for entity (x), deleting
And player timeout the server after +/- 10 ~ 15 players why ?

Linux is fixed now. Rejoice!~

Hi guys, i just tried to enable OneSync on my debian 9 server (on a vanilla server, with last updates), and players can’t see others, so i think it’s not fixed at all.

So, if there is some linux owners who can confirm this issue, that would be great, thank you very much.

1 Like

Linux is fixed but latest versions are not available yet.

@PichotM Ah ok, thank you very much for your reply.
I think i’ll rent a windows serv for onesync testing so.


hello guys i have one bug on my server sometimes when someone shooting he crashes
any one know how to fix that?

alguem me ajude , quando entro em um servidor da esse erro aki :

[Window Title]
FiveM Error

[Main Instruction]

An error at cfx_curl_x86_64.dll+1C81D caused FiveM to stop working. A crash report is being uploaded to the FiveM developers. If you require immediate support, please visit and mention the details below.

Legacy crash hash: uncle-apart-kitten

[^] Ocultar detalhes [Show information] [Fechar]

[Expanded Information]
Crash signature: cfx_curl_x86_64.dll+1C81D
Report ID: … [uploading?] (use Ctrl+C to copy)

Use English on the forums please :slight_smile:

You need to update your es_extended and essentials and activated PVP in essentials

Developer Arma 3 in script I threw myself challenge to make a server fiveM in 64slot challenges succeeded after 6 weeks of attentive dev, I have a server that works, I started with a ti pieces and reunited several pieces in trelle to make a rp server with mapping, plus 30 trades, 300 car modder brand, what else to ask except waiting for the 128 slot, thanks to fiveM for all their work provided for the small creator of server role-play. world-Life to see the job make server.

So we did a OneSync test earlier today for about an hour, we run a Linux machine (Ubuntu) and we were using the latest “alpine” build from the site provided by FiveM on their front page.

Within the hour we noticed a few things:

  • Server was decently stable until we reached more than 58 players on.
  • Due to the amount of people crashing and rejoining it began to kick people for "Not enough client slot ID: "
  • Shortly after hitting 63 players, people would start to get timed out with a crashing error in rough batches of 12 people until the server went below 32 slots again.
  • People get very annoyed at you on discord if they keep crashing 10 minutes after playing :wink:

Common Errors and Crash reasons:

This appeared and was a common crashing issue when users attempted to load in large amounts of streamed objects, clothing or interiors (939.1 KB)

Vehicles that spawned in by NPC’s often decided to duplicate into giant build-ups and explode, this is not particularly uncommon on normal 32 player FiveM but it was definitely more evident and common using OneSync

At the beginning of the hour around 20 people were kicked indvidually shortly after connecting amd govem this error. There is little more I can give information wise about this, as I never suffered it myself and anybody that did rejoined and ignored any requests to give logs :expressionless:

Some feedback about the system already from players:

  • People adored the new voice chat system, Sounded so much clear’er and doesn’t cut out anywhere near as much as it did when I tried it with a group of 10 people a few months back.
  • People are loving the idea of 64 slots over 2x 32 slot servers (like mega hype).
  • Connection times have been reported as faster when loading in (weather this be something that was just a fluke while we were testing or not I am not sure).

Anyway that is going to be all for this post! I am in no way intelligent or knowledgeable enough in this area to be able to give you any in-depth explanations about any of this, so I apologise if anything in this post is just repeated or junk - Just trying to do my little bit in the development of the whole thing and transcribe the problems our community found to you guys :smiley:

Doing great work! Thank you :heart:


i have that error and my server crash it

terminating with uncaught exception of type boost::exception_detail::clone_impl<boost::exception_detail::error_info_injectorboost::system::system_error >: boost::random_device: cannot open random-number pseudo-device /dev/urandom: No file descriptors available
no /proc/self/maps, not on linux?

Memory around native instruction pointer (0x7f8bf893b21f):
0x7f8bf893b20f 00 00 b8 0e 00 00 00 31 d2 bf 02 00 00 00 0f 05 …1…
0x7f8bf893b21f c3 48 63 ff 50 b8 24 00 00 00 0f 05 48 89 c7 e8 .Hc.P.$…H…
0x7f8bf893b22f a0 a2 fd ff 5a c3 48 63 ff 50 48 63 f6 b8 3e 00 …Z.Hc.PHc…>.
0x7f8bf893b23f 00 00 0f 05 48 89 c7 e8 88 a2 fd ff 5a c3 85 ff …H…Z…

Got a SIGABRT while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.

any one know how can fix that?


When we go into our server with OneSync, we always join a solo session. We tried this with 4 people and we have no error messages at all. You guys know why this can happen? (without OneSync it works good)


After starting to use OneSync we have came into a problem with one of the Natives Functions. SetEntityLocallyInvisible isn’t working? Is there any reason OneSync would cause this? And is there another native I should be using if so? Also is there any plans in the future to add a way to set Voice Channels again like using NetworkSetVoiceChannel with Mumble, also people who live far from where the server is hosted have a timeout issue with Mumble. They keep connecting and reconnecting over and over again, not allowing them to hear any voice in game, and no one can hear them.

1 Like


Do you have one solution for fix this crash please ?

Thanks for all


I have set up a 64 player server but this error occurs after the player logs in. What should I do?

Someone already told you on the discord that this is not OneSync related but rather a column missing your database.

Read the error

The database has been resolved, Even if ■■■■■■■ is disabled, an error message appears.

This error is not related to onesync