Stuck at downloading server resources [FIXED]


Sorry for not following the template, but I don’t think any of that information is required for this particular post, if necessary I’ll edit the post and add it. Sorry for moderators if this triggers you.

My FiveM is freezing or taking SIGNIFICANT time to download resources while joining servers. It freezes at 2/6.89MiB on the resource load screen. I tried to remove the load screen from my server, but then it just freezes with another resource. I have 100/100, so these downloads should be extremely fast. No one else has the same issue as me.

Does anyone have an idea? Thanks in advance

Everything is up-to-date. No mods installed, cleared cache, re-installed game, restarted the computer.


It doesn’t freeze, it just takes a VERY long time. Been downloading the 6.89 MiB for over an hour now.

GTA V version? Latest update
Up to date? Yes
Legit or Pirate copy? Legit
Steam/CD/Social Club? Steam
Windows version? 10 Home
Did you try to delete caches.xml and try again? Yes
Error screenshot (if any) None
System specifications i7 4770k, GTX 1080, 32GB 3200mhz RAM.
What did you do to get this issue? Played FiveM
What server did you get this issue on? Local, several online


I noticed that the downloads are ONLY slow for this one server, and ONLY slow for me? Does anyone have an idea?

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the FiveM community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!

Please fill out the template to get better help.

Hope this is enough, not quite sure where to find the GTA V Version.


20 character limit

If this only occurs on one server then this ‘one server’ has some network issues. So, alternatively, play on another server.

It’s my own server, lol.

However, the issue only happens to me. None of the other players.

Is there no one out there that can help me with this?

is there any fix on this issue??? I’m having the same… no answers anywhere on these forums… just happened randomly… i dont get it

Are you using a VPS or your server? Is this your own server?

I fixed my issue by: Switching my VPS’es Network Card.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.