Spawning custom vehicle causes client to crash without any errors

I just finished making a custom vehicle, it appears fine in OpenIV, but as soon as I loaded it up in my development server and tried to spawn it, the game just crashes and doesn’t give an error.

I checked if it was the handling by using metas for a vehicle that I know work(and swapping in my vehicle’s name where it should be), but same result.

I also double checked textures for the vehicle, it appears to have all the ones it needs.

And yes, the .yft (8.5MB) and .ytd (12 MB) are less than 16 MB

CitizenFX log:
CitizenFX.log (145.4 KB)

Thank you in advance for any help.

Edit: Just saw it also causes the server to give a bunch of “server thread hitch” (having trouble counting but it gives about 30 of them.

It appears fine in OpenIV, but does it appear fine on GTA 5 SP?

I havn’t tested that yet, let me try that now

Edit: Not sure if this could have been part of the issue, but there was an update to GTA5 that steam wasn’t giving me until I validated game files, so I guess I’ll see if that was it when this is done.

Edit 2: while waiting for the update, I think I may have found another issue of some missing textures from a resource I added tot he car(it didn’t supply the needed ones), so I’ll also have to test that when its done updating.

Alright, not sure which of the two it was, I suspect the missing texture, but now it works and the game doesn’t crash.

Thanks for your time @akeem!