[Solved] echo-table-virginia crash error

So for the past month members of my server have been dealing with an echo-table-virginia crash error when they got near the Mission Row Station. For the life of me we could not figure out what was causing the error and why other servers were not having this issue.
We have custom interiors made by Gabz for Mission Row, and Vespucci. Other servers we talked to also have these interiors but they didn’t seem to have this issue.
I’m not writing all this to seek help as today (a few minutes ago in fact) I had just solved the issue and gotten a better understanding of the echo-table-virginia error, so i’m writing this because there is no information about this error and how to solve it.

What is “echo-table-virginia”?
This error is related to the loading of MLO’s. The error occurs when an MLO attempts to load but the configuration of one or more MLO’s is incorrect or overlapping. This seems to mostly apply to MLOs that utilize meta files.

How did you fix it?
In some custom interiors, like those from Gabz, utilize an “interiorproxies.meta” file. What happened is that Gabz uses the same starting value (in this case “2000”) in all his interiorproxies.meta files. This leads to an overlapping of data that the game can’t handle leading to the crash. To fix this, I made sure each interiorproxies.meta file had a different starting value with about 2000 in seperation. (So Mission Row 2000, Vespucci 4000)
After doing that the crashes stopped entirely. So now i’m spreading this finding so that if anyone else runs into this issue, they know where to look.

Why didn’t the other servers have this issue?
It’s simple, that meta file was missing from their files. A friend from another server was kind enough to send me their copy of Mission Row by Gabz to troubleshoot with and I found that while the file was called for in the fxmanifest.lua, it was completely missing on their end.
While deleting the troublesome meta file is indeed another solution, I prefer to have the interiorproxies.meta file as the creator intended on it being there.

interiorproxies.meta example:

<?xml version="1.0" encoding="UTF-8"?>
<SInteriorOrderData>
  <startFrom value="2000" />
  <proxies>
	<Item>insert_name_here_</Item>
  </proxies>
</SInteriorOrderData>

I hope this post helps a server dev out there who may be suffering from that same issue with no clue on where to start.

Anywho, thanks for making it this far and have a wonderful day. :slightly_smiling_face:

1 Like

Technically, you don’t need it.

1 Like


I have this problem what do I do to solve it I couldn’t understand the solution here