Running FiveM in a Hyper-V VM with full GPU performance for testing ("GPU Partitioning")

If anyone is wondering how to do this for AMD and getting stuck when finding the file:

Device Manager > Display Adapter > Properties > Driver Details

There will be DLLs in there and you’ll find some that all have the same beginning. Now you can look for that DLL name in the C:\Windows\System32\DriverStore\FileRepository\ and then transfer it to your VM like OP says. You shouldn’t have to transfer the file he mentions.

Ok so im a little confused. What exactly does “while VM being turned off” mean? like how am I too run code when the VM is off?

I was able to get this working with my 2080 on my laptop, however, since ‘Enhanced Session’ need to be disabled it appears this truly only works why trying to run this VM as a server and not a client.

For reasons I need to run within a VM on my machine and was wondering if anyone has figure out a way to enable audio and bluetooth on the VM with this setup. It would be fantastic if it’s possible to pass through the audio and bluetooth the same way we are passing the GPU through. Thanks in advance for any help!

Im stuck here, any help?

@Bucci_Bucci are you running vm gen 2?

Hi everyone. I had this working fantastically well with an AMD card. No driver problems etc. Except… I couldn’t get OpenGL to play nice through it. Anything that invoked an OpenGL instruction would just crash. Tried different AMD drivers, nothing. Does anyone have the OpenGL + AMD + Hyper-V combo working? (i know… not really FiveM specific)

For OpenGL, you could try building the Mesa D3D12 backend which should be meant for a fairly similar purpose.

Yea, It works now, but how do I install Nvidia driver? Seems to kinda be working, but Nvidia driver install says I dont have a nvidia card? How to fix it? image

@Bucci_Bucci do steps 5 and 6 on the original post. You don’t install the Nvidia drivers on the guest

thanks @deterministic_bubble . Do you know if OpenGL is supported/functioning at all with GPU-P? Or is it just a glitch with my setup :frowning:

It is not directly supported, no, but that’s why Microsoft bothered to fund the support for OpenGL wrapped on top of DX in Mesa.

1 Like

After running I get: