[Release] Smart car system

The current interact sound version kinda garbage., So if you want to hear the sounds you need to use a older version. Here is mine: horizon_interact.rar (26.4 KB)

Is it okay if I create a github for this project and sent the link into this thread? I’ve made some small changes to the script where if you are in sport mode, all other modes cannot be used anymore (Some were still usable) and that once enabled, that all currently active modes stop
So like
When you enable sportmode whilst in rear reverse camera, it cuts the camera and brings back to normal view and enables sport mode

So back to the front of the question

Is it okay for me to create that github and sent the link in a comment on this thread?

1 Like

Sure, why not.

Thank you, greatly appreciate.

This is, for anyone reading a slight modification which disables the autodrive and the rearview camera with the lines when sportmode is enabled, and does not allow you to enable them again when in sportmode

Again, all credits go out to @Marcus_Wagner for the script, I only made some small changes

1 Like

mee too

The latest release of interact sound not working as it should. I link mine so you can use that and it will work. interact.rar (26.4 KB)

There’s a way to change the notifications position?

NVM i managed :smiley:

Does the autopilot work on the planes?

@1041407710 Maybe, but not made for that.

For some reason I had this working, then made some changes to my tesla and it’s not working.

I can spawn my tesla with /car teslams without issue.

In the config.lua I have:
Config.AllowedModels = {“teslams”}

I have also changed the AutodriveKeycode to 10 (should be Page Up) but nothing is happening.

Also for the sake of further testing I put this all into a fresh server just to make sure nothing was interfering.

I tested out the keycode change and it works just fine for me. I think you have a problem with the vehicle model.