[RELEASE] renzu_garage - Public , Private, Realistic and Housing Parking, w/ Garage Inventory | v1.5

salam…nak tanye mcm mane nak join server ni…baru main ni…

tuan kenapa saya tak boleh masuk server tuan

English only in this thread. thanks :heavy_heart_exclamation:

does anyone know why this happens? 2021-09-17 23-50-28 (streamable.com)

I’ve been trying to set up multiple Police garages but when I place a police car into any of the other police garages and try to get them back out it says that I don’t own any vehicle. Is it not possible to have multiple of the same job garage?

garage = “Police Garage”, --Mission Row
job = “police”,
Type = “car”,
Dist = 3,

garage = “Sandy Police Garage”, --Sandy
job = “police”,
Type = “car”,
Dist = 3,

Hi, I need some help. I want to work a little with this great system to implement it to our server. However, I have an error message when trying to execute the sql query, specifically those lines that have the “LONGTEXT” feature. The error is as follows:

“BLOB, TEXT, GEOMETRY or JSON column ‘park_coord’ can’t have a default”.

I appreciate the help!

Try using this latest sql
@Steven_Garcia

Thanks for the quick response and help.
I tried running that query, but now when I try to add the park_coord line, I get this new error:

You have an error in your SQL syntax; refer to the manual corresponding to your MySQL server version for the correct syntax to use near ’

Apology im not in desktop yet…cant help much

You can try this

ALTER TABLE owned_vehicles
ADD park_coord LONGTEXT NULL;

Hahaha don’t worry. It’s awesome that you give support from wherever you are and I thank you for that. Indeed, that way if the query is executed without any problem. Thanks!

1 Like

Hey, first question / comment ever on cfx.
First off, you put out amazing stuff!

I am kind of stumped though. Impound garage, cant see car in it. Error is:
Uncaught TypeError: Cannot read property ‘brand’ of undefined. html/script/js:241

Any suggestions? Ive been troubleshooting. Sorry to bother!

does your impound garage have a vehicle ?
try using the latest patch to avoid the undefined error. get it at github.

to test the impound, use /impound to any player owned_cars

@eSNAKE
Multi Job Garage works with me.

you only need to change garage id

1 Like

It is amateur hour over here, I apologize.

I was using esx_policejob impound function.

Apparently I am not firing on all cylinders. All is well with /impound.

Thank you so much!

1 Like

Thanks for checking that for me Renzu, I must have messed something up along the way.

Hey there, just had the HUD and Radar not showing up after entering the Garage.

after bit of search i found it, if anyone else is searching:

client\client.lua at Line 3381

under: ClearFocus()

add:
DisplayHud(true)
DisplayRadar(true)

like this:

1 Like

bruh you didnt “find” sh!t… you just went to the github where i requested a fix from OP and OP posted the fix and uploaded it to the github… stop trying to farm karma or whatever you call it on the fivem forum.

yes and you are now the best “karma farm” haha

Renzu, I downloaded your latest files and tested the Police Garage 1 and Police Garage 2 at Mission Row and both were working as you showed in your video. When I moved Police Garage 2 up to Sandy it would say that I don’t have any vehicles. Now, all I did was change the x, y, z coordinates with the ones below. I’ve changed the location back and forth several times with the same result. Very odd.

garage_x = 1865.78556640625,
garage_y = 3699.9792602539,
garage_z = 32.554322814941,
spawn_x = 1869.14071411133,
spawn_y = 3693.3401757813,
spawn_z = 32.640564727783,
heading = 207.86824005127,

If you get a chance could you please enter those coords into your Police Garage 2 and test it. Or if someone else could test it that would be appreciated.

edit: I’m using police vehicles set up in the database and purchased at renzu_vehicleshop.

ill test it and give you a input

with my test after moving the coordinates to paleto bay.

no vehicle, but after you park a vehicle there, it should be showing.
https://streamable.com/qg0rh6

the job garage only is always unique (vehicle garage id must be stored here)