[Release] [Free] [Standalone] | v2.1 DeathScript

hey man, i’m having trouble setting the adres and adrev command for group.admin.
i put add_ace group.admin command.adrev allow in permissions.cfg in the vmenu resource folder and it doesn’t work.

can you send me over a pre configured file with the commands so i can copy paste? much thanks.

Hey PipBoi,

As I’ve already mentioned in my last reply, the permissions for those commands start with “DeathScript.” and not “command.”,
So commands would look something like this;

add_ace group.admin "DeathScript.AdRev"
add_ace group.admin "DeathScript.AdRes"

add_ace group.admin "DeathScript.AdRevAll"
add_ace group.admin "DeathScript.AdResAll"

add_ace group.admin "DeathScript.ToggleDS" # toggle DeathScript 

This is due to the fact that I’m not using the built-in command ace check, but instead using the IsPlayerAceAllowed() native to unify commands and keybinds permissions.

Good luck

Ah that would make more sense I will give it a shot thanks!

I have tried the new string you listed above both with and without the quotation marks, but still not able to bypass the revive.


In the config.js is says command.AdRev is correct.
I copied the following into both permissions and the the server cfg but still not having any luck:
add_ace group.admin “DeathScript.AdRev”
add_ace group.admin “DeathScript.AdRes”

add_ace group.admin “DeathScript.AdRevAll”
add_ace group.admin “DeathScript.AdResAll”

add_ace group.admin “DeathScript.ToggleDS” # toggle DeathScript
Is there any support discord to get some help and provide pictures? Thanks again.

Hey,

Sorry for the troubles, I’ve just tested it out, and it seems to be working just fine,

although I did it from the server console as shown here;

but it should also work from a permissions.cfg or server.cfg just fine.
though, something I didn’t address is using allow at the end of the ace command, as I just figured that it’s needed at least in the console, otherwise it will throw me an error as shown;

try using add_ace group.admin "DeathScript.AdRev" allow
and the same goes for the rest of the commands, and let me know if it doesn’t work and I’ll be more than willing to help :hugs:

P.S: I’ve gone ahead and updated the post to reflects the latest changes and make it a bit more understandable, as well as updating the comments in the sh_config.js file :smirk:

I worked on it for a while and followed what you were saying. Dont know what it was but it started working after one of the changes I made. Thank you.

Hello, I have a problem, when I revive the inventory it is disabled and I cannot open it, how can I fix it? I use the ox_inventory

Glad to know things are working for you, and good luck