[Release][ESX] Inventory HUD - 2.4 (properties, trunks, players, shops, storages ...)

i cant seem to be able to use Ammo or “clip” in the inventory, the use button is grayed out and doesnt work when i drag ammo to use seen here : sxcu.net - file ZpxmRE.gif other than that amazing resource very well made :slight_smile: :+1:

guys i have some problems with that, it is on a whole different language, and if i change the language in config.cfg it doesnt change anything. and also some images doesnt load like the heavy pistol’s, and i cant do anything with these items which doesnt have a picture because u have to drag its picture to the give or throw etc. options, so its kinda doesnt work for me.

Did you rename the resource something different than it was originally named?

Has anyone gotten this to work with esx_weaponshop doing the method for shops doesnt allow you to purchase items

2021-04-17 01-58-44.mkv (32.5 MB)
Cant give, thief or take items. Anyone know why? I tried with change can_remove to INT (11) but I have te same problem…

Some of the weapons simply doesnt have an icon, how can i add icons? i made some and moved them to the other icons folder but nothing happened, do i have to change anything, like to link the picture to the item?

You need to have the same name in the Item than in the image

it has, but nothing happened.

Worked around with some css and got a pretty clean look

Thanks!

hey would you be able to dm me and tell me how you did that? Im really curious on how to add different icons for things, would be a major help in moving forward.

Hey :slight_smile:

If you want to not have the original es_extended inventory show up at all, i suggest you head over to

es_extended/client/main.lua

and add – infront of every ESX.ShowInventory()

so just replace every ESX.ShowInventory() with
–ESX.ShowInventory()

how to delete this ? :slight_smile: :

can someone help me how can i hide the player name and only show ID number when giving item? TQ

How can i get 1/0 for items such as bread?

yo it isnt English how do i change that

Can’t seem to figure out whats going on here so looking for help please.

I have this error on both the esx_inventoryhud_glovebox and trunk.
path is esx_inventoryhud_glovebox/client/esx_glovebox-cl.lua:51: attempt to index a nil value (upvalue ‘PlayerData’)
When i look at the code
RegisterNetEvent(“esx:setJob”)
AddEventHandler(
“esx:setJob”,
function(job)
PlayerData.job = job
end
)

I dont really see anything wrong? Any help would be appreciated!

in the ui.html on line 13 change to

<script src="locales/en.js"></script>

how do you change this to english (use, Drop, Give)? Screenshot - f016f306824dac6ef4bd3116c62dd8cf - Gyazo

like the @beastinrapper said, change the <script src="locales/cs.js"></script> at ui.html

would the inventory script be causing an issue where when i drop an item it drops to every player on the map?