RegisterPedheadshotTransparent Opacity Build 2189

General guideline is: if you ‘need help’, do not post here. Post in the right support section instead.

WARNING: THIS IS NOT A HELP SECTION

If you post here without knowing what you’re doing you’ll most likely get suspended. You should probably instead post in:


For a good bug report you should probably include:

  1. Client (production/canary) and FXServer version
    Canary, Latest Windows artifact, Game build 2189
  2. What you expected to happen
    Its should be like this
  3. What actually happens
    Opacity become maybe a 30%
  4. Category of bug (eg. client, server, weapons, peds, native)
    native
  5. Reproducible steps, preferably with example script(s)

Just use this code with Game build 2189
it works fine without any issue with build 1604

local playerPos = GetEntityCoords(PlayerPedId())

local player = PlayerId()

local tempHandle = RegisterPedheadshotTransparent(PlayerPedId())

local timer = 2000

while ((not tempHandle or not IsPedheadshotReady(tempHandle) or not IsPedheadshotValid(tempHandle)) and timer > 0) do

    Wait(10)

    timer = timer - 10

end

local headshotTxd = 'none'

if (IsPedheadshotReady(tempHandle) and IsPedheadshotValid(tempHandle)) then

    headshotTxd = GetPedheadshotTxdString(tempHandle)

    headshot = headshotTxd

end

just wanted to follow up this
issue still exist in 2189 only
1604 and 2060 is okay.

im actually using this
hotlink the image via NUI HUD as http url

https://nui-img/pedmugshot_01/pedmugshot_01?t123
RegisterPedheadshotTransparent(PlayerPedId())
Issue too much transparent

I have the same problem on build 2189 with this native

This native also makes transparent characters hair when they are very balck (not tested on other builds)