RedM won't work

Hi Guys,
For the past 3 months I’m not able to run RedM as well as RDR2. I was able to run it before tho, R* could not help me - nothing worked.
Games lunches in task manager but not on the screen, I did try everything that i found online to make it work but nothing worked :confused:

MY PC specs:
INTEL I7-4790K
PATRIOT DDR3 16 GB (not sure about mHz)
Gigabyte GA-Z97X-GAMING 5 motherboard
MSI R9 390X 8GB
650w psu
As I’ve said, everything worked before but it doesn’t now. :confused:

Imgur
Here’s the error that I always get.

Kind Regards,
Adasco

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the Cfx.re community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!
:mascot: