RedM stucks on loading screen when iwanna join any server

Before you begin, please read the Client FAQ and Common Questions topic.

If you did not find a solution, fill out the following template and remove this top text.

**RDR2 version? RDO **
**Up to date? yes **
**Legit or Pirate copy? legit **
**Steam/Epic Games/Social Club? epic **
**Windows version? windows 10 **
**Did you try to delete caches.xml and try again? yes **
Error screenshot (if any)
**System specifications: ryzen 5 5600x 16fb ram ddr4 gtx 2060 super **
**What did you do to get this issue? nothing **
**What server did you get this issue on? family

Latest CitizenFX_log file
.dmp files/report IDs

If an issue with starting:
RDR2 folder screenshot
RDR2/x64/dlcpacks screenshot
Filepath to RedM folder
RedM client folder screenshot
Did you try to disable/uninstall your Anti-virus?
Did you start Rockstar Games Launcher not as admin?

Also add what you already tried so far.


Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!

You have any luck with this? We have someone on our server having this issue and have tried everything. The only thing that worked temporarily was deleting her character from the database and then she was able to load back in but two days later the same issue was back.

Same issue for 3 people and the more i dig on this problem im seeing none of you are loading the next initial function in the F8 the next line wee should see is INIT_BEFORE_MAP_LOADING now what could be stopping it