RedM refuses to launch. Receive "Error during auto-sign with ROS using Steam: Failed to connect to port 443 after x ms: Timed out"

RDR2 version?
Red Dead Online.
Up to date?
Legit or Pirate copy?
Steam/Epic Games/Social Club?
Windows version?
10. Checked for updates and fully up to date.
Did you try to delete caches.xml and try again?
Error screenshot (if any)
System specifications
GPU Nvidia 2700
CPU Ryzen 7 3500
What did you do to get this issue?
Opened RedM as usual and have been getting this error during the signing in on steam part of the launch every time I’ve tried since yesterday.
What server did you get this issue on?
I am unable to connect to any servers now, however was on Goldrush prior to this.
Latest CitizenFX_log file
CitizenFX_log_2023-02-28T100139.log (1.5 KB)

I have attempted restarting, reinstalling RedM, clearing cache, attempting to log-in through the Rockstar Launcher (it also cannot connect to their servers for an unknown reason) and even using a VPN to launch the game which did not work and gave an SSL error.

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!

You ever find a fix, having the same issue

Dude I’ve been having this problem for a while and cant seem to fix it. If anyone finds anything any help would be greatly appreciated!