RedM Launcher Download Reboots Modem

RDR2 version?
1.0.1232.62

Up to date?
Yes

Legit or Pirate copy?
Legit

Steam/Epic Games/Social Club?
Social Club

Windows version?
Windows 10

Did you try to delete caches.xml and try again?
Yes

Error screenshot (if any)
N/A

System specifications
Intel i7-9700k
Nvidia EVGA RTX 2070 Super
G.Skill F4-3400C16-8GVK (32gb)

What did you do to get this issue?
Attempted to download RedM and cache via launcher.

What server did you get this issue on?
N/A, Never got past install.

Latest CitizenFX_log file
N/A (Couldn’t download)

.dmp files/report IDs

If an issue with starting:
RDR2 folder screenshot
RDR2/x64/dlcpacks screenshot
Filepath to RedM folder
RedM client folder screenshot
Did you try to disable/uninstall your Anti-virus?
Yes.

Did you start Rockstar Games Launcher not as admin?
Yes.

Also add what you already tried so far.
Uninstalled & Reinstalled RedM
Uninstalled & Reinstalled RDR2 (Also played through intro)
Restarted PC. Restarted Router.
Updated router firmware. (Cisco DPC3941T)

Additional Note
This was the only application I have had any sort of issue like this with before, and is specific only to the RedM launcher when it attempts to download the 3gb cache. It downloads a fair bit, then the internet slows to a crawl before the router resets itself and remains in a downed state until I shut the program off, then the router boots back up again without fail.

I had no issue like this with FiveM and I regularly download 50gb+ games without issue as well. Internet speeds typically aren’t an issue either.

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the Cfx.re community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!
:mascot:

I have the exactly same problem, cant find any solution to the problem.

My solution to this problem was to connect through a VPN and download the client that way. It was the only way I could get the modem to stop resetting every time I wanted to download the cache.