RedM Devs, it's possible your female models are broken on ALL servers!

Face and body customization is broken on all female models. Despite customization, all female models have a default face and all have the athletic body type. I have joined a few servers to test this out, along with other friends, and the result is that it is a REDM issue and not a server issue. PLEASE NOTE: ON THE USER END YOU APPEAR AS INTENDED, as in, YOU will see yourself as the correct body type and the correct customized face, BUT NO ONE ELSE DOES. This is why I am sure, MOST people don’t know this is happening to them, but it’s happening to ALL female models in multiple, if not ALL servers. This does not apply to male avatars.

Some things that were tested:

  1. I made a new character with no makeup (in case it’s an overlay issue), and only minor changes to the face (only made the nose small and the chin smaller). Left everything else the same. She still showed up default faced with athletic body.
  2. Made another character and didn’t touch her face. Only made her body the small body type. She still showed up with the athletic body type.
  3. Deleted that character and made one without doing any changes to the face from the default and made her the largest body type. Still showed up as the athletic body type.

Again, from my perspective, she looked normal (as I intended) but to all others, she looked as described above. I have had multiple friends try this, and it is the same result. So it’s not a me problem, but a global one.

Here is some evidence:

VIDEO SAMPLE

PHOTO EXAMPLE

Before the most recent update, I had found a glitch that temporarily fixed it. After the most recent update, all female models are broken all the time and there is no glitch.

Please note that after the most recent update this fix DOES NOT WORK. All female models are permanently default faced and have the athletic body type. For the purpose of data I will list the old fix here.

Previously, the fix I had found was:

The coat was the MAJOR problem, but other items trigger it, and so does the clothing store menu.

When an outfit was made that did not include a coat, then the user refreshed like 3 or 4x after I exiting the clothing menu, they mostly always looked correct.

The trick was to make an outfit with no coat on, exit the clothing menu, and refresh 5/6x.

  • If after this, ANY article of clothing was removed, default face and body appeared. So after any the outfit was made, the user could not take off ANY part of clothing off at any time or the wrong face (default face/body) would appear.

If an outfit was made that included a coat, it doesn’t matter how many times the user refreshed, or what article of clothing was taken off, the user would have the wrong face/body.

I’ve done a lot of other testing which I did not list here. It would just be too much to post.

2 Likes

Uh.

RedM does nothing regarding character models? Have you even tried on RDR SP mods? RDO? Considered providing repro steps instead of ‘evidence’?

1 Like

As said the above, that’s clearly not a RedM issue. However, after looking a bit on the character you did. Shapes looks very irrational. Is there any chance that you passed too small (< -1.0) or too big (> 1.0) value to _SET_PED_FACE_FEATURE. Because in that case, the game have a hardcoded limits for network. So it applies on your end, but for other clients this value will be synced with default value (0.0). This how it worked since V.
Otherwise, again, we can’t help you until you provide repro scripts.

1 Like

I sincerely thank you Disquse and deterministic_bubble being nice about this and taking the time to respond.

I apologize for the lack of technical data.

This is data that friends of mine and I have gathered as players. We are not developers, and have no knowledge of coding/scripting. Although I am embarrassed about my noob evidence, we’re just concerned and doing the best we can as players.

Our servers told us it is a RedM issue and our testing through gameplay at multiple servers have the same result, so reaching out to RedM seemed like our last resort to be heard and have this fixed. I will try reaching out again to the servers, relay this information, and get the repo steps as suggested.

Lastly, I strongly believe this is not more widely known because of the circumstances:
1. your av must be female & 2. despite it happening to all females, you would only know about it by seeing yourself in a photo someone else took of you, or a video from someone’s else’s POV… because, again, in YOUR game you always look correct, but to everyone else you do not.

I have been told “this isn’t happening to me” by people who do not have female avatars and tested it themselves by seeing themselves through someone else’s game or having someone else take a screen shot of their avatar for comparison.

But yes, I will relay this to the servers as best I can and will update. Really, thank you so much. :heartpulse: